Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru-Impreza.org > Newbies - Say Hello Here

Subaru Impreza Forum

turbo problem already!
Reply
 
LinkBack Thread Tools Display Modes
Old 11 Jul 2013, 09:56 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jul 2013
Posts: 1
turbo problem already!

hi,i'm new to turbo cars having recently bought a 96 sti.its obviously had bits done to it (air filter,dump valve,exhaust etc) but i dont know much more.when i got it the turbo would kick in at about 4k and was really fast but now if anything the car seems faster at lower revs than before but i cant feel the turbo kick in at all.the dump valve still seems to be doing exactly the same and the boost guage is still reading the same.i have looked for air leaks and am pretty sure there arent any.has anyone got any ideas please?
Offline   Reply With Quote
Old 11 Jul 2013, 12:37 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: turbo problem already!

ws it mapped for the mods it had?

turbo kicking in at 4k is pretty late.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 11 Jul 2013, 04:19 PM   #3 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: turbo problem already!

if you can't feel the tubby come on boost,you've just got use to it,mines the same,it the tubby fails you WILL know about it....keep driving and enjoy it..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
turbo problem td04 chris2000 Engine Bay 3 15 Dec 2012 08:25 PM
HKS Turbo Timer Problem DJAS Technical General 1 11 Jul 2010 08:50 PM
Turbo problem?? j66lrn Interior 13 24 Apr 2009 07:54 AM
turbo problem? GHBNIC Technical General 1 01 Jun 2007 06:58 PM
could it be a turbo problem? jls Engine Bay 9 31 May 2007 08:31 PM


All times are GMT. The time now is 02:33 PM.

Archive: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.