Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru-Impreza.org > Newbies - Say Hello Here

Subaru Impreza Forum

Hi and Boost problem?
Reply
 
LinkBack Thread Tools Display Modes
Old 17 Apr 2012, 10:07 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 4
Hi and Boost problem?

Bear with me as this is my first Subaru that i've owned...

I've just bought a classic subaru turbo 2000 and it won't rev over 4000 - 4500. Once it reaches this it jerks and throws me forward.

It has got a boost valve fitted and someone looked at it for me and screwed it all the way in and said it would be better but went for a drive and as soon as I put my foot down a bit a juddered and cut out completely.

Any advice would be greatly received.

Thanks!
Offline   Reply With Quote
Old 17 Apr 2012, 10:59 PM   #2 (permalink)
Young Scooby
 
Lamby2k12's Avatar
 
Join Date: Apr 2012
Location: bury st.e.edmunds, suffolk
Posts: 88
Re: Hi and Boost problem?

U Tryed winding it out and put a bit more boost on?
__________________
if in doubt flat out
Offline   Reply With Quote
Old 17 Apr 2012, 11:19 PM   #3 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,531
Re: Hi and Boost problem?

remove the boost control and see if it drives ok
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 18 Apr 2012, 06:10 AM   #4 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 4
Re: Hi and Boost problem?

When i wind it out thats when i can't rev over about 4500 revs.

If i take it off have i got to replace the pipe its on?
Offline   Reply With Quote
Old 18 Apr 2012, 08:09 AM   #5 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,531
Re: Hi and Boost problem?

yes you will, also make sure there is a restrictor pill in the correct place, you dont want to be running a MBC really, they only alter the boost and dont change the fuelling or ignition maps.
hth
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 18 Apr 2012, 08:33 AM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Hi and Boost problem?

MBC= BANG!!!!...bin it asap...what year is the motor??
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 18 Apr 2012, 08:50 AM   #7 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,531
Re: Hi and Boost problem?

Quote:
Originally Posted by The Pilot View Post
MBC= BANG!!!!...bin it asap...what year is the motor??
well it says what I was trying to but with less typing
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 18 Apr 2012, 08:58 AM   #8 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Hi and Boost problem?

Quote:
Originally Posted by bugeye_bob View Post
well it says what I was trying to but with less typing
..short n to the point
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 18 Apr 2012, 09:18 AM   #9 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 4
Re: Hi and Boost problem?

Quote:
Originally Posted by The Pilot View Post
MBC= BANG!!!!...bin it asap...what year is the motor??
It's a turbo 2000 on a w plate (2000).

I'm going to get it removed asap. Any advice on removing it all and best place to get what I need?

Sorry I'm a complete newbie with Subaru's! Only had Vauxhalls before! lol
Offline   Reply With Quote
Old 18 Apr 2012, 09:29 AM   #10 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Hi and Boost problem?

why in gods name do to55ers inssist on putting MBC's on motors that can be mapped....no funking idea at all...all you really need to do is rig the pipe work back into the solanoid and go for a remap....
nuf said about VX ownership
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
boost problem mushimunro Engine Bay 6 16 Dec 2011 12:54 PM
boost problem - stutter/judder under boost occuring Dazzaboy7 Subaru Impreza Discussions 8 06 Oct 2011 12:04 PM
boost problem dansubaru Modifications - Tips and Tricks 15 12 Mar 2010 09:10 PM
boost problem dansubaru Modifications - Tips and Tricks 0 04 Sep 2009 08:50 AM
boost problem? ben281083 Engine Bay 35 03 Jun 2009 11:51 AM


All times are GMT. The time now is 02:46 PM.

Archive: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.