Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Modifications - Tips and Tricks

Subaru Impreza Forum

ecu reset problem
Reply
 
LinkBack Thread Tools Display Modes
Old 05 Apr 2010, 10:19 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Feb 2010
Posts: 24
ecu reset problem

hi all got a my99 fitted a full system no cats panel filter walbro pump and running optimax i have read that i need to do a reset on the ecu

i have read that you have to plug in the black and green plugs under the steering column

with engine at temp

turn on ignition but not start engine

depress throttle pedal then up half way up hold for 2 seconds engine light comes on

this light is not coming on i drive for about 10 seconds then it flashes i dont think it is working

has anyone got any advice

can i take the battery off for half hour?? then how do i have to drive the car slowly or hard???? the engine will be cold

any help gratefully received
Offline   Reply With Quote
Old 05 Apr 2010, 11:37 AM   #2 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: ecu reset problem

You can disconnect the negative terminal and then press the brake pedal for 30 sec this allows the ECU to be wiped and reset. Reconnect the terminal. Once reset before going to boost hold the revs at 2600rpm.

Quote:
The Ecu will then learn for the next 200 miles
__________________
Pete.

Offline   Reply With Quote
Old 05 Apr 2010, 06:02 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Feb 2010
Posts: 24
Re: ecu reset problem

hi thanks for reply

so i get the engine warm

turn of ignition

disconnect the battery neg lead

turn on ignition and depress brake for 30 seconds

reconnect battery and start engine

in neutral hold revs at 2600 rpm

how long do i hold the revs for???

is that it

thanks jody
Offline   Reply With Quote
Old 05 Apr 2010, 07:29 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: ecu reset problem

Quote:
how long do i hold the revs for???

Drive for at least 5 minutes keeping the revs down & road speed.

That's it.
__________________
Pete.

Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
performance problem - 03 WRX al9955 Engine Bay 13 29 Sep 2010 01:47 PM
Welcome Thorpy joins our Forums... The_Team Newbies - Say Hello Here 5 03 Nov 2009 09:12 AM
STi problem (diff./clutch/gearbox) Mooseman Technical General 9 25 Sep 2009 08:50 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM


All times are GMT. The time now is 06:54 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.