Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Modifications - Tips and Tricks

Subaru Impreza Forum

boost problem
Reply
 
LinkBack Thread Tools Display Modes
Old 30 Jun 2009, 08:39 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 14
boost problem

hi i have just brought a m impreza turbo import with a full exhaust decat and up pipe i was told it was 280bhp but no way is it.it dont seem to boost early what shall i look for and what can i do so it runs 1bar of boost??
Offline   Reply With Quote
Old 01 Jul 2009, 08:34 AM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: boost problem

need more info on the car bud
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 01 Jul 2009, 04:42 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 14
Re: boost problem

its a jap import with td05 turbo gas flowed up pipe and down pipe and exhaust green air filter and thats it i think i was told it was 280bhp but its nothing compared to my 300bhp pulsar.it boost up at about 4500 rpm how much boost do they run standerd and how much can they run on standerd manegment?
Offline   Reply With Quote
Old 01 Jul 2009, 05:14 PM   #4 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: boost problem

if its a WRX,you are looking around the 240/250 bhp mark,doubt its been mapped or anything, .8/.9 bar standard pressure,it will seep slower than a pulsar as its a bigger heavier car,plus if it's not mapped will still be on the Factory settings etc
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 02 Jul 2009, 09:52 AM   #5 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Re: boost problem

Few things you can check. Firstly if you haven't got a boost gauge then get one and see how its holding boost? next up how is the boost controlled? could well be worth cleaning the boost control solenoid / does it have the brass restrictor in place within the boost control pipework? have you checked the ECU for fault codes? If you are looking for more power then I would suggest remap with a decent boost controller, this should give you the power you are wanting...
Offline   Reply With Quote
Old 02 Jul 2009, 01:43 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 14
Re: boost problem

it has a engine light on but a soon as you rev it goes out then back on tick over comes back on.how do u do the fault check?i dont think its running .8 and what is the most bhp can you run on standerd scooby engine and were could i get it remapped and how much?
Offline   Reply With Quote
Old 02 Jul 2009, 02:00 PM   #7 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Re: boost problem

Now you are asking....need to dig back through the memories LOL. If I remember correctly you need to plug in the 2 black connectors at the base of the steering column to retrieve any fault codes. A long flash = 10 and a short flash = 1

Not sure how much power a standard scoob engine can take cos it will depend on mileage how well its been serviced etc. I would say around 300 or slightly more you should be fine.
Offline   Reply With Quote
Old 02 Jul 2009, 03:34 PM   #8 (permalink)
Senior Scooby
 
holyfield's Avatar
 
Join Date: Oct 2004
Location: heckfield hampshire
Posts: 1,662
Re: boost problem

still hovering around nelson
Offline   Reply With Quote
Old 02 Jul 2009, 08:22 PM   #9 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: boost problem

Quote:
Originally Posted by dansubaru View Post
it has a engine light on but a soon as you rev it goes out then back on tick over comes back on.how do u do the fault check?i dont think its running .8 and what is the most bhp can you run on standerd scooby engine and were could i get it remapped and how much?
How to read ECU codes Classic Impreza
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 02 Jul 2009, 10:21 PM   #10 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Re: boost problem

Quote:
Originally Posted by holyfield View Post
still hovering around nelson
hell yea mate just like a bad penny!!!!
Offline   Reply With Quote
Old 12 Mar 2010, 10:23 AM   #11 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 5
Re: boost problem

Quote:
Originally Posted by The Pilot View Post
if its a WRX,you are looking around the 240/250 bhp mark,doubt its been mapped or anything, .8/.9 bar standard pressure,it will seep slower than a pulsar as its a bigger heavier car,plus if it's not mapped will still be on the Factory settings etc
Not at all! Jap imports have a different wiring loomb and ecu which put out 280bhp stock............uk models are 250/260bhp!
Offline   Reply With Quote
Old 12 Mar 2010, 12:18 PM   #12 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: boost problem

lol uk model are 218 or 225 lol
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 12 Mar 2010, 12:19 PM   #13 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: boost problem

Scoobypedia | Trusted knowledge for everything Subaru | Knowledge / Specifications

Easier then arguing over a Batman thread.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 12 Mar 2010, 04:06 PM   #14 (permalink)
Cool Scooby
 
QUINNtheDAWG's Avatar
 
Join Date: Aug 2009
Location: drumquin NI
Posts: 247
Re: boost problem

its not the horses its how u use them
Offline   Reply With Quote
Old 12 Mar 2010, 04:34 PM   #15 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: boost problem

Quote:
Originally Posted by QUINNtheDAWG View Post
its not the horses its how u use them
I bet you say that to all the girls lol
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
boost problem - stutter/judder under boost occuring Dazzaboy7 Subaru Impreza Discussions 8 06 Oct 2011 12:04 PM
boost problem gav2777 Technical General 5 27 Feb 2009 11:39 PM
boost cut problem (help) meldino Engine Bay 2 06 Aug 2008 06:59 PM
strange boost problem! doc__dave Engine Bay 11 30 Aug 2007 07:09 PM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM


All times are GMT. The time now is 10:36 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.