Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Modifications - Tips and Tricks

Subaru Impreza Forum

how much boost?
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Feb 2009, 03:22 PM   #1 (permalink)
Young Scooby
 
T21CDR's Avatar
 
Join Date: Aug 2008
Location: dunfermline,fife,scotland
Posts: 59
how much boost?

hey, can anyone tell me what is a safe psi to be running on a 93 wrx 225 import with the td05h turbo.
i think with the boost controller turned right down it was boosting at 10psi (ish)
but i have it at about 14 psi just now is this ok?
__________________
BURN RUBBER NOT YOUR SOUL.
Offline   Reply With Quote
Old 15 Feb 2009, 03:59 PM   #2 (permalink)
Cool Scooby
 
Join Date: Sep 2008
Posts: 490
Re: how much boost?

Quote:
Originally Posted by T21CDR View Post
hey, can anyone tell me what is a safe psi to be running on a 93 wrx 225 import with the td05h turbo.
i think with the boost controller turned right down it was boosting at 10psi (ish)
but i have it at about 14 psi just now is this ok?
hi ive been told 16 psi is standard on them so think your ok there mate
Offline   Reply With Quote
Old 15 Feb 2009, 04:31 PM   #3 (permalink)
Young Scooby
 
T21CDR's Avatar
 
Join Date: Aug 2008
Location: dunfermline,fife,scotland
Posts: 59
Re: how much boost?

cheers mate.
__________________
BURN RUBBER NOT YOUR SOUL.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
3 port boost solinoid on a 93 wrx import T21CDR Engine Bay 1 24 Jan 2009 02:42 PM
help engine jerk and code 45 came up, boost no constant limfk7 Engine Bay 3 05 Sep 2008 01:46 PM
strange boost problem! doc__dave Engine Bay 11 30 Aug 2007 07:09 PM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM


All times are GMT. The time now is 04:23 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.