Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Modifications - Tips and Tricks

Subaru Impreza Forum

ecu issue i think or fueling
Reply
 
LinkBack Thread Tools Display Modes
Old 27 Jun 2014, 06:29 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Location: cambridge
Posts: 45
ecu issue i think or fueling

hi ive just got myself another wrx wagon on a 95 plate.
ive done td05 turbo conversion and have fitted a z4 ecu.
it is running standard airbox and recirculating valve only mod is prodrive backbox.
after an ecu reset it boosts nicely upto 0.9 bar and holds well but after driving less than a day it goes into limp mode and boosting at 0.5 bar.
ive checked for leaks and there are none.
so today i decided to put the old 3b ecu back in and it worked perfectly boosting and dropping like it used to.
does anyone have any suggestions atal as i like the power i had with the z4 and would like to keep it.
thanks ben
Offline   Reply With Quote
Old 27 Jun 2014, 07:38 PM   #2 (permalink)
Scooby Fanatic
 
alunian's Avatar
 
Join Date: Aug 2010
Posts: 746
Re: ecu issue i think or fueling

you need to get it remapped if you have fitted a bigger turbo. pretty sure the standard WRX only had a TD04.
__________________
Jack Burton, Big Trouble In Little China: This is Jack Burton in the Porkchop Express and I'm talkin' to whoever's listening out there.
Offline   Reply With Quote
Old 27 Jun 2014, 10:12 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Location: cambridge
Posts: 45
Re: ecu issue i think or fueling

thanks for the reply
it did originally have a td04 turbo but the td05 and z4 ecu are a match its what the sallon wrx run
Offline   Reply With Quote
Old 01 Jul 2014, 07:52 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Location: cambridge
Posts: 45
Re: ecu issue i think or fueling

i figured out what it was today i re gaped my plugs and realised i changed my pipe from intercooler to inlet with a different silicone one i thought at the time it felt a bit flimbsy it was expanding under boost and almost flapping in and out it couldnt handle it so put the standard back on and all cured now
Offline   Reply With Quote
Old 02 Jul 2014, 07:15 AM   #5 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: ecu issue i think or fueling

glad you got it sorted matey
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
faulty MAF issue? alunian Engine Bay 4 05 Jun 2014 05:47 PM
Possible HG Issue? redscoobie Engine Bay 7 15 Mar 2014 02:33 PM
over fueling??? kennethsmith1982 Technical General 3 01 Dec 2011 07:14 PM
Fueling problems....cont... pbturbo82 Engine Bay 4 28 Oct 2011 02:21 PM
Issue Nine No Longer Member (Batfink) Subaru Impreza Discussions 6 12 Mar 2006 04:31 PM


All times are GMT. The time now is 03:44 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.