Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Modifications - Tips and Tricks

Subaru Impreza Forum

Wrx Sti Prodrive Bugeye lack of power?
Reply
 
LinkBack Thread Tools Display Modes
Old 21 Oct 2011, 10:01 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Oct 2011
Location: Birmingham, West Midlands
Posts: 2
Exclamation Wrx Sti Prodrive Bugeye lack of power?

I have a 02 reg Blue Wrx Sti Type UK Prodrive -
I bought the car with a cheap ebay adjustable boost bleed valve, it used to be flat as a pancake untill 4.5-5k rpm where it would suddenly launch you back like F*** i noticed this was a problem and decided to put back onto boost solenoid(as standard) and it ran rough and would boost at around 2.5k but only 10 psi and hold back alot, i changed the maf sensor and the new maf sensor it would even rev properly, i put the old maf back on and it now is misfiring but not as bad and goes like stink when it wants to other times i stamp it it goes to sleep on me?


anybody who has experienced this and has any possible related advice please comment i am lost and not happy lol

(new to forums sorry if i've not posted in the right bit? not sure? )
Attached Images
File Type: jpg IMG00019-20111004-1314.jpg (166.7 KB, 8 views)
Offline   Reply With Quote
Old 22 Oct 2011, 07:56 AM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Wrx Sti Prodrive Bugeye lack of power?

take it to a expert for a diagnostic check, you cant do the manual check for issues like on a classic,I hate the MBC, especially as the Newages are so easy to get remapped safely,
No location so cant really point you towards a reputable garage.
hth and welcome along
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 22 Oct 2011, 11:18 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Oct 2011
Location: Birmingham, West Midlands
Posts: 2
Re: Wrx Sti Prodrive Bugeye lack of power?

Thanks for the reply, i am in Birmingham, West Midlands.
Offline   Reply With Quote
Reply

Bookmarks

Tags
wrx sti misfire no power


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Prodrive Alloys for Bugeye Bpm Exterior 0 16 Apr 2009 06:56 AM
Misfire and lack of power stagcar Engine Bay 24 25 Sep 2008 10:27 AM
low power and power surges at high revs tony5144 Subaru Impreza Discussions 2 10 Apr 2008 04:53 PM
Help needed: Hesitation and lack of power Bailey73 Technical General 4 30 May 2007 08:51 PM


All times are GMT. The time now is 02:10 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.