Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Members List

Subaru Impreza Forum

sean_c's Profile

sean_c Offline

Fresh Scooby

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. sean_c
    07 Oct 2008 09:57 AM - permalink
    sean_c
    Hey guys, a friend of mine has a 97 impreza 1.6l gl but the "check engine" light has come on lately and I noticed that its ticking over very high, about 2,000 revs, he brought it to a garage to get plugged in and they said it seems to be losing air maybe in one of the vacuum pipes? does this sound right? I checked all the pipes and they seem fine, another thing i noticed was that the accelerater sticks alot so I took off the injector and cleaned it out..no good tho, now im thinkin could it be one of those modules on the injector maybe? has anyone ever heard of the 1.6 given this kind of trouble? any advice would be greatly appreciated!
    Cheers!
    Sean_c

About Me

  • About sean_c
    Biography
    Trainee mechanic, have 2 scoobies, love rallying and motorsport
    Location
    Tralee
    Interests
    Rallying, guitar,
    Occupation
    Trainee Mechanic
    Your Car
    93 impreza turbo
    Your Mods
    new shape legacy alloys in gold, high spoiler, front splitter, uprated exhaust, turbo timer, sony head unit

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 12 Oct 2008 08:20 PM
  • Join Date: 14 Jul 2008
  • Referrals: 0

All times are GMT. The time now is 08:46 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.