Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Exterior

Subaru Impreza Forum

Annoying headlight problem
Reply
 
LinkBack Thread Tools Display Modes
Old 02 Nov 2009, 05:14 PM   #1 (permalink)
Fresh Scooby
 
cult88's Avatar
 
Join Date: Oct 2009
Posts: 49
Annoying headlight problem

hi guys, i'm a new impreza owner after finally jacking in my MG ZS (many unhappy hours spent under the bonnet of that woeful K Series engine....). anyway, i'm pretty happy with the scooby apart from a niggling headlight problem.

basically, when i put the dipped headlights on sometimes the right one doesn't work and i've also noticed that when this happens the full beam symbol lights up on the dashboard. i'm thinking a loose connection somewhere?

is this is a common problem? any ideas what's wrong? thanks.
Offline   Reply With Quote
Old 02 Nov 2009, 07:24 PM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Annoying headlight problem

Quote:
Originally Posted by cult88 View Post
hi guys, i'm a new impreza owner after finally jacking in my MG ZS (many unhappy hours spent under the bonnet of that woeful K Series engine....). anyway, i'm pretty happy with the scooby apart from a niggling headlight problem.

basically, when i put the dipped headlights on sometimes the right one doesn't work and i've also noticed that when this happens the full beam symbol lights up on the dashboard. i'm thinking a loose connection somewhere?

is this is a common problem? any ideas what's wrong? thanks.
Check for loose, faulty, cut, frayed wires and dodgy earths
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
STi problem (diff./clutch/gearbox) Mooseman Technical General 9 25 Sep 2009 08:50 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM
Another problem...GRRRRRRR sjay72 Subaru Impreza Discussions 1 07 Feb 2007 11:29 PM
MY99 Turbo ignition problem M-Tech Engine Bay 7 27 Aug 2006 06:56 AM


All times are GMT. The time now is 09:58 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.