Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Boost problems ..... help please!!
Reply
 
LinkBack Thread Tools Display Modes
Old 25 Jan 2011, 09:07 AM   #1 (permalink)
Fresh Scooby
 
024AST's Avatar
 
Join Date: Jan 2011
Posts: 1
Boost problems ..... help please!!

hey guys, just wondering if anyone can help me out. I own a 02 bug eye STI and it is not catching boost like it used to. The turbo winds up and the blow off sounds but at 4000 when my turbo kicks in, there is no whip lash anymore. The car is sluggish and feels like an RS that is running rich!

Things I have done to try and solve the problem is:
*change spark plugs (old ones were gone and you can feel the difference with the new ones when the car is going before the turbo kicks in)
*clean air filter (sensor and everything is fine)
*replaced the vacuum line hoses going to and from boost solenoid
*cleaned the t-piece with braklean (was all clean and brass orfice was fine)

I think the problem might be that my boost solenoid is not working..
When I was cleaning it with braklean and the car was in service mode (I had plugged the two green plugs together under dash) the fan was starting and stopping like its supposed to but the solenoid wasn't clicking and braklean wasn't shooting out when I sprayed it in.

I checked how much a new solenoid was with subaru today and they gave me a price of $360!

Does anyone no if this is a problem with my boost solenoid or if its something else? Also, if I change it to an aftermarket boost controller will I need a tune?
Offline   Reply With Quote
Old 25 Jan 2011, 01:10 PM   #2 (permalink)
jd
Obsessed Scooby
Paid & Proud
 
jd's Avatar
 
Join Date: Mar 2005
Location: here
Posts: 6,414
Send a message via MSN to jd
Re: Boost problems ..... help please!!

I would check all boost hoses first, could be a leak.
__________________
blah blah blah
Offline   Reply With Quote
Old 25 Jan 2011, 02:24 PM   #3 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Boost problems ..... help please!!

get it on a dyno and see what they say, will tell you whats going on, could be any number of things.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 21 Feb 2011, 08:59 AM   #4 (permalink)
Fresh Scooby
 
Join Date: Feb 2010
Location: Yorkshire
Posts: 8
Re: Boost problems ..... help please!!

Hi have you sorted this yet?

Putting a newage in service mode wont make the boost solenoid function.

To get the boost solenoid working you will need to follow the instructions on the below thread. I had to ask too -

Newage Boost Control Solenoid Cleaning
Offline   Reply With Quote
Old 21 Feb 2011, 09:23 AM   #5 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Boost problems ..... help please!!

Neutral position switch
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
boost problems Quill Engine Bay 1 24 Jan 2011 11:03 PM
having problems with the boost?!? ashtray69 Technical General 3 21 Jul 2009 10:23 PM
Boost problems after rad hose split!??? jtanner Technical General 1 05 May 2009 02:06 PM
boost and idle problems d6nyb Engine Bay 5 17 Nov 2007 11:26 AM
Help 1995 turbo 2000 boost problems projectsubaru Subaru Impreza Discussions 8 03 Mar 2007 12:23 AM


All times are GMT. The time now is 09:59 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.