Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Loss of Power
Reply
 
LinkBack Thread Tools Display Modes
Old 16 Dec 2010, 03:25 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Loss of Power

Hi, guys i was flooring my 01 WRX the other day & the turbo kicked in as usual & the car started pulling then all of a sudden its like i hit a wall & you could hear a dump of air from somewhere.

Am i right in thinking its some kind of pipe from the turbo thats cracked?I checked all the pipes i could see for obvious signs but couldn't find anything. I really hope the turbo hasn't blown.

Any help please, much appreciated.
Offline   Reply With Quote
Old 16 Dec 2010, 03:32 PM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Loss of Power

sounds like you've blown a pipe off or fractured it,as for the hitting a wall feeling,sounds like boost spike/over boost,the cold air plays havoc with some turbo motors,does the car run now? and CEL flash up??
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 16 Dec 2010, 03:40 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Re: Loss of Power

Yes the car still runs & no cel light. Just when i boot it the revs start climbing, turbo starts pulling & then it stops pulling & a loud noise of escaping air.
Offline   Reply With Quote
Old 16 Dec 2010, 03:44 PM   #4 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Loss of Power

if the turbo has gone you'll have blue/white smoke bellowing out,is it standard,no mods??
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 16 Dec 2010, 04:02 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Re: Loss of Power

Good to know defo not the the turbo then. Yeh its got a stage 1 performance pack.
Offline   Reply With Quote
Old 16 Dec 2010, 04:08 PM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Loss of Power

just thought,your not running a bailey dump valve on it are you??
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 16 Dec 2010, 04:11 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Re: Loss of Power

As a matter of fact i am, as it was bought already installed. Could that be the problem?
Offline   Reply With Quote
Old 16 Dec 2010, 04:12 PM   #8 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Loss of Power

yup,that'll be it then,the diaphram will have collapsed,bin the bloody thing and put the standard recirc back on it
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 16 Dec 2010, 04:14 PM   #9 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Re: Loss of Power

Awesome! Ill try that. cheers mate. Really glad i posted on here before taking her into subaru garage
Offline   Reply With Quote
Old 16 Dec 2010, 04:15 PM   #10 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Loss of Power

no worries
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 17 Dec 2010, 12:38 PM   #11 (permalink)
jd
Obsessed Scooby
Paid & Proud
 
jd's Avatar
 
Join Date: Mar 2005
Location: here
Posts: 6,414
Send a message via MSN to jd
Re: Loss of Power

ahhh Baileys........................
__________________
blah blah blah
Offline   Reply With Quote
Old 21 Dec 2010, 11:33 AM   #12 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Re: Loss of Power

Back again guys. I just fitted a new forge piston dump valve (sounds awesome) but still the same problem. Fractured pipe?
Offline   Reply With Quote
Old 21 Dec 2010, 02:20 PM   #13 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Loss of Power

ok then,must be a boost leak,check the pipework round the solanoid,accross to the turbo and then to the inlet manifold..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 21 Dec 2010, 08:58 PM   #14 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: Loss of Power

Spend a bit of time taking the bcs, turbo and intercooler pipes off and checking them. They may look ok, but I bet there is a crack/leak that only shows itself when under pressure. Gently bend the pipes and examine them all over. Then make sure all the clamps are tight on refitting.
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Old 21 Dec 2010, 09:01 PM   #15 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 11
Re: Loss of Power

Thanks for the info guys. Gonna make a start on checking the pipes in the morning.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Urgently Needed - Loss of power trez Engine Bay 3 19 Jul 2010 10:28 PM
power loss pbfldavis General Chat - Anything about Anything 1 29 May 2010 05:33 PM
power loss pbfldavis Subaru Impreza Discussions 0 29 May 2010 11:12 AM
power loss badgerico Engine Bay 2 20 Aug 2007 07:12 AM
Help please. Loss of power, loads of smoke. Mr_Wid Technical General 44 06 Oct 2005 10:48 PM


All times are GMT. The time now is 09:59 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.