Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

HELP!
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Jan 2014, 12:43 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2014
Posts: 8
HELP!

Hi all!

got a problem with my 1998 uk subaru classic

the car seem to hesitate under boost. it doesnt seem close to 200 bhp at all

i have noticed that my clutch is starting to slowly slip in 3 and 4 gear. would this cause the problem?

any help would be great. thanks
Offline   Reply With Quote
Old 14 Jan 2014, 09:56 AM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: HELP!

Quote:
Originally Posted by subz2000 View Post
Hi all!

got a problem with my 1998 uk subaru classic

the car seem to hesitate under boost. it doesnt seem close to 200 bhp at all

i have noticed that my clutch is starting to slowly slip in 3 and 4 gear. would this cause the problem?

any help would be great. thanks
Id be tempted to fix your clutch before you panic if its known to be faulty.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:16 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.