Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Idol problem. Engine cuts out.
Reply
 
LinkBack Thread Tools Display Modes
Old 16 Nov 2012, 05:06 PM   #1 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Idol problem. Engine cuts out.

Hi there I have a 1998 Subaru impreza terzo when I start the car it runs ok for around 10 seconds then the revs drop and it will start to miss until it cuts out. It has been raining for the past week or so would this have anything to do with it. I have just ordered new ht leads so hopefully this will help. Any help will be much apreasiated. Thanks guys
Offline   Reply With Quote
Old 16 Nov 2012, 06:03 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Idol problem. Engine cuts out.

possibly maf as well
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 16 Nov 2012, 06:11 PM   #3 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

I disconnected the maf and it didnot seem to make a difference
Offline   Reply With Quote
Old 16 Nov 2012, 08:43 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Idol problem. Engine cuts out.

iirc it should shut off unless its fooked, so sounds like the maf is nackered, dont drive it untill you can get it confirmed, dead maf can equal dead engine.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 17 Nov 2012, 05:44 AM   #5 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

sorry i wrote that wrong when i disconnected the maf the car died immediately so i think the maf is ok do you think it could have something to do with the spark plug gap also when i got the terzo there was no boost pipe running from the wastegate actuator to the boost solenoid so i bought a t pice and ran it from the boost solenoid to the t pice but there is no restrictor pill in the hose from the turbo nipple to the wastgage actuator will this cos me problems. ps i will be more than happy to put up pics if this can help.
Offline   Reply With Quote
Old 17 Nov 2012, 10:36 AM   #6 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Idol problem. Engine cuts out.

Quote:
Originally Posted by terzo View Post
I disconnected the maf and it didnot seem to make a difference
this test method is a myth, start it and run it when it cuts out whip the plugs out and check the colour of the plugs.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 17 Nov 2012, 10:56 AM   #7 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

about 2 weeks ago i removed the plugs and all 4 seemed fine but when i removed them i gave all 4 a sand down and when i done this i think i might have made the contact points wider than they should be so when my ht leads come through i will remove the plugs and check all 4 gaps to make sure they are 0.7m
Offline   Reply With Quote
Old 17 Nov 2012, 11:04 AM   #8 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Idol problem. Engine cuts out.

Quote:
Originally Posted by bugeye_bob View Post
this test method is a myth, start it and run it when it cuts out whip the plugs out and check the colour of the plugs.
fair dos, not had a maf for 8 years now lol
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 29 Nov 2012, 12:16 AM   #9 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

today i done the plug gaps to 0.7 mill and replaced the ht leads with new ones and this hasn't solved anything i have been looking on forums and ive came across an article saying that when you disconnect the battery the ecu resets itself im thinking this could be causing the problem as when i turn the car on it runs ok for about 5 seconds then it runs lumpy misfires and dies. as my car has some mods full dcat exhaust induction kit fmic and a abc chip i think it will take the ecu some time to adjust so tomorrow am going to put a Jerry of petrol in her and just keep trying to get her to idle . i read that the best way to do this is to turn the ignition to the on position but not to start the car for around 15 sec so the ecu can calibrate then crank her. if this fails any idea what could be causing my problem and where would be the best place to start looking after i try the ecu reset
Offline   Reply With Quote
Old 29 Nov 2012, 08:58 AM   #10 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Idol problem. Engine cuts out.

after the initial 10 seconds of running how long does it run for in total
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 29 Nov 2012, 10:29 AM   #11 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

Say another 10 seconds max. The first 5-10 seconds it ticks over ok then it starts to missfire and cough and it finally stalls
Offline   Reply With Quote
Old 29 Nov 2012, 10:36 AM   #12 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Idol problem. Engine cuts out.

u sure the immobiliser isnt kicking in ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 29 Nov 2012, 10:44 AM   #13 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

I'm not sure there is an alarm but it has been disconnected how would I test to see if it the central locking? I only have one key for my terzo
Offline   Reply With Quote
Old 29 Nov 2012, 11:20 AM   #14 (permalink)
Fresh Scooby
 
terzo's Avatar
 
Join Date: Oct 2012
Posts: 12
Re: Idol problem. Engine cuts out.

I tried locking the door then opening it then starting the car and it sill is cutting out after around 5 seconds
Offline   Reply With Quote
Old 29 Nov 2012, 01:31 PM   #15 (permalink)
Fresh Scooby
 
Join Date: Nov 2012
Posts: 3
Re: Idol problem. Engine cuts out.

is the car a import or uk ? if its a import theres 2 green conectors under the dash and two black ones they need to be joined together with the ignition off then after switch on ignition and this some how resets the ecu or go onto www.jollygreenmonster.co.uk and it shows steps of how to do this
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
p1 engine problem coombesy Technical General 8 07 Jan 2012 06:26 PM
Engine Problem - Cuts out under high load House Engine Bay 3 08 May 2011 10:38 PM
engine problem subaruterzo Engine Bay 10 23 Feb 2010 05:50 PM
Engine cuts out Chip682 Engine Bay 0 06 Aug 2009 11:34 AM
Teams plan engine cuts to head off FIA. News_Bot Formula News 0 10 Nov 2008 12:01 PM


All times are GMT. The time now is 09:50 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.