Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

impreza bad running
Reply
 
LinkBack Thread Tools Display Modes
Old 15 Nov 2012, 02:10 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Dec 2011
Posts: 30
Exclamation impreza bad running

]hi all problems again when new engine was fitted first of all it run rough lumpy when reved then sorted it self out every now and again it would do this but i would stop and wait 15 mins and then car would run fine again but last week this wasnt the case i started car up got bout 5 mins away from parents house car felt a bit slugish anfd then the rough running came back seems like a missfire so i cruised home very slowlyand hasnt run right since then
i have done commpresion test all cylinders 145
checked coils and plugs 1 coil was cracked replaced that
checked all intercooler pipes etc
oil level is fine
none of above solved my problem so
only thing i have found is if i diconnect maf it wil idle bad BUT lower rpm is smother till u get to 3000 rpm then rough running is back could this be my problem as i am low on money and need car to get to my new job
thanks guys has any1 had same problems il give anything a try its just buying new bits i wana be sure before i spend
Offline   Reply With Quote
Old 15 Nov 2012, 08:50 AM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: impreza bad running

tbh,your goin to continue chcuking time n money at it,get it to a dealer/specialist n get it plugged in,if it's not reving its probably in safe mode...
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 impreza 2.0 gl awd fuel pump fault stopped car running bigblue Technical General 1 29 Nov 2011 11:10 PM
poor running andrewautomotive Technical General 5 13 Dec 2010 12:04 PM
running in...? zzmilo Subaru Impreza Discussions 1 21 Aug 2010 09:00 PM
My impreza's running HOT!!! andyroo Technical General 16 22 Jul 2009 08:57 PM
New WRX - Running In skylight Subaru Impreza Discussions 43 19 May 2004 04:01 PM


All times are GMT. The time now is 09:57 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.