Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

turbo problems ?????
Reply
 
LinkBack Thread Tools Display Modes
Old 06 Nov 2012, 08:34 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Nov 2012
Posts: 4
turbo problems ?????

hi all just new on the site i have a white impreza turbo wrx sti hawkeye with a 2005 wrx sti engine its running 360 brake and has a vfr 34 roller baring turbo it has been running great untill latley when im driving the car and put the foot down it dosent seem to boost much any more if any at all car starts runs drives fine no coughs or stutters but revs out through the gears without the turbo kicking in? it just happend over night no build up so i am at a loose end here with it .. previous to this i had a purple classic shape impreza turbo 2000 that i had little to no trouble with any info on the problem would be well aprecieated
Offline   Reply With Quote
Old 06 Nov 2012, 09:39 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: turbo problems ?????

what dump valve is it running ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 06 Nov 2012, 10:11 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Nov 2012
Posts: 4
Re: turbo problems ?????

hi there ive been running the standard bv just now as was on the hunt for a chattering one but this seems to be taking up all my time just now cheers
Offline   Reply With Quote
Old 07 Nov 2012, 10:15 AM   #4 (permalink)
Fresh Scooby
 
Join Date: Jun 2012
Location: St Helena
Posts: 18
Re: turbo problems ?????

Hi
If i were you i would go for the HKS Dump Valve SSQ3
They are around the 30 pound figure on ebay.
They sound sweet and unlike other piston dump valves, these are less prone to leaks
and the more boost, the tighter seal you get.
only one down fall with the HKS Dump Valve is that you may have to take the back of the dump valve and put another spring in with the factory one, because before you do this to the dumpvalve it blows of at about one and half thousand revs, and when you are comeing down hill in first gear at low revs and dips the clutch and hit the brake the car cuts out
but after you have put the spring the in it, it blows of around three thousand revsand sorts the cutting out problems out,
Offline   Reply With Quote
Old 07 Nov 2012, 10:41 AM   #5 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: turbo problems ?????

assuming the car is well serviced and the correct fuel is being used,

the NPS Neutral position switch) would be the next thing to check, ideally you need to get it on a laptop to see what is actually going on, it may not have any error codes as the light isnt on, but a laptop will allow you to see if the NPS is working and to see if the MAF or 02 are faulty,

as you havent filled out your location I cant suggest where would be best.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 07 Nov 2012, 10:43 AM   #6 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: turbo problems ?????

and stay well away from chav valves until it`s running 100 %, they don't add any performance and can be detrimental to the running of the car unless mapped correctly.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 08 Nov 2012, 09:04 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Nov 2012
Posts: 4
Re: turbo problems ?????

hi there had the scoob pluged in to a diagnostic machine and it came back with a lambda sensor fault but im assuming that because i have a de cat on the scooby and with it mapped i thought this may also be the fault but surley this cant be the turbo probs after the diagnostic check im fairly positive that or hoping more should i say that its just a vacume hose split or leaking
Offline   Reply With Quote
Old 08 Nov 2012, 09:58 PM   #8 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: turbo problems ?????

If you've a lambda fault you would need addressed first. Who mapped it? Drive it off boost till its sorted........
Offline   Reply With Quote
Old 08 Nov 2012, 09:59 PM   #9 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: turbo problems ?????

do u have a boost gauge or access to the laptop again, you want to be looking at the - psi for a vacuum leak, if it doesn`t go into the - it shows a leak,
also what was the actual error code for the 02 ? the cat 0420 code is what typically comes up for a de cat.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 13 Nov 2012, 08:32 AM   #10 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: turbo problems ?????

if your getting sensors faults then that may well be your issue, get it to a specialist to get it checked out.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! staling / idel problems! 1998 turbo pjwakefield Engine Bay 5 26 Aug 2011 01:40 PM
Info: 97/98 Turbo Air Cleaner/Turbo Unit/Air Intake System Pics 2002pete Modifications - Tips and Tricks 4 18 Feb 2011 09:39 AM
Turbo Problems ????? Rosswrx53 Engine Bay 8 02 Aug 2007 06:07 PM
Help 1995 turbo 2000 boost problems projectsubaru Subaru Impreza Discussions 8 03 Mar 2007 12:23 AM
TDO4 turbo, MY1999 uk turbo, for all the none believers brumbrum Subaru Impreza Discussions 47 01 Dec 2006 06:53 PM


All times are GMT. The time now is 09:14 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.