Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

HELP NEEDED!! Starting issues after rain!!
Reply
 
LinkBack Thread Tools Display Modes
Old 12 Oct 2012, 10:09 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Oct 2012
Location: Warrington, North West
Posts: 3
HELP NEEDED!! Starting issues after rain!!

First of all I'm new on here...... so hello

It has been great looking through all the posts and trying to figure out what is wrong. I am on my 2nd Scooby now, 1st was a MY93 WRX which I loved and had when I was single. It's taken me 5 years to get my hands on another and even convinced the Mrs it is a 'sensible' family car haha

OK, so the car is a MY95 N plate impreza WRX. Having plenty of fun in it, my issue is that after it rains it won't start!!

It turns over and cranks away but just doesn't seem to fire. After reading through the posts I have checked the fuel pump, which primes on ignition, the battery is fine, and everything else seems fine as it starts fine when dry. The guy I got the car off did say that he had starting issues with it but it was fine after he changed the Engine Coolant Temp sensor.

I have done the self diagnostics and it threw up Crankshaft Position Sensor and Throttle Position sensor faults. I have purchased these along with a Walbro 255 fuel pump.

My thinking is that it may not even be these as the car starts fine in dry, I sprayed the full engine bay along with electrical connections with WD40 and the car was ok and started for a few weeks.

It sounds more like an electrical fault to me, moisture getting into somewhere??

Any help would be greatly appreciated!!

Thank you all
Offline   Reply With Quote
Old 12 Oct 2012, 10:36 AM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: HELP NEEDED!! Starting issues after rain!!

has it got the standard airbox fitted? and is the vent cover still in place on the bonnet ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 12 Oct 2012, 11:09 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Oct 2012
Location: Warrington, North West
Posts: 3
Re: HELP NEEDED!! Starting issues after rain!!

It has the standard air box with an upgraded panel filter and both vent panels are still in place (I think) You have me thinking now lol

I'm really just stumped, as I think it could be electrical but don't want to replace the full wiring loom and then it be something easy.

Thank you for the quick reply, I've learned quite a bit from your replies
Offline   Reply With Quote
Old 12 Oct 2012, 12:00 PM   #4 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: HELP NEEDED!! Starting issues after rain!!

If honest id be tempted to try a genuine ECT, I know the last owner claimed to have swapped it but its a cheap and easy swap.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 12 Oct 2012, 12:05 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Oct 2012
Location: Warrington, North West
Posts: 3
Re: HELP NEEDED!! Starting issues after rain!!

I will try one of those too, no harm in trying is there. Although on inspection it does look brand new still compared to the rest of the engine. It's just really doing my head in :S

It would be ok if we lived in California with a rain shower a couple of times a year but with it constantly raining and coming to winter I need it sorting as its my daily ride

Thanks again
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Issues ? kelcig Technical General 2 10 Mar 2012 01:08 AM
Electrical Starting Issues Redxlll Electrical (Including ICE) 2 11 Apr 2011 07:25 AM
New Boy needs help!! Starting issues Goulders Technical General 9 24 Oct 2010 06:46 PM
starting issues jay@sedevelopments Technical General 1 12 May 2010 06:11 PM


All times are GMT. The time now is 06:37 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.