Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

engine tickover does not sound right
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Apr 2012, 07:17 PM   #1 (permalink)
Young Scooby
 
weobleyscoobywagon's Avatar
 
Join Date: Oct 2010
Location: herefordshire
Posts: 79
engine tickover does not sound right

i was driving for about 6 mile at 80mph slowed down when i got to my village parked the car up. while i was waiting for the turbo timer to finish i noticed that the engine was not ticking over correct. it sounded if it was being starved of fuel or air. it sounded like it was going to stall. while this was happening the rev counter stayed on its usual spot. i have just over the quarter mark of fuel in it. anyone have any ideas?
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
STI EXHAUST SOUND stiimpreza1984 Subaru Impreza / Rally / Car Scene Videos 4 15 Jan 2009 11:44 PM
Stumbing / missing tickover to 3500rpm wicksy5508 Engine Bay 8 17 Mar 2008 05:08 PM
Wrx Sound madmax220668 Exterior 3 22 Dec 2007 08:53 PM
tickover problem pfd Technical General 19 12 Apr 2007 05:49 PM
some help plz. Air sound robdewell Engine Bay 4 07 Apr 2006 02:56 PM


All times are GMT. The time now is 11:58 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.