Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Boost problem on 95 impreza
Reply
 
LinkBack Thread Tools Display Modes
Old 20 Mar 2012, 09:29 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Feb 2012
Location: Glasgow
Posts: 3
Question Boost problem on 95 impreza

Hi i am looking for a little help on this one.
My 95 impreza will boost upto 0.9 bar but this will only last 1 hour ,1 day,1 week then will drop down to 0.5 bar then out of the blue it will go back up to 0.9 bar.
I have checked all the pipework and it looks ok.
Its getting a little frustrating as everyone i speak to has a different opinion of whats at fault and its no fun running at 0.5 bar.
The only mods i have is a decat 2.5" exhaust system and bov.
Any help will be much appreciated.
Offline   Reply With Quote
Old 21 Mar 2012, 08:25 AM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Boost problem on 95 impreza

just take it too a expert then, less stress and will probably be cheaper then changing everything everyone suggests.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 22 Mar 2012, 09:14 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Feb 2012
Location: Glasgow
Posts: 3
Re: Boost problem on 95 impreza

In the process of trying to find an expert to help out, i did put my car into my local subaru dealer and they had it plugged in but found no fault, not sure they were too keen to get into it.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
boost problem - stutter/judder under boost occuring Dazzaboy7 Subaru Impreza Discussions 8 06 Oct 2011 12:04 PM
Boost problem HELP!!! cirus Engine Bay 10 04 May 2010 04:46 PM
Boost Problem!!! BARNEY Engine Bay 2 04 Jul 2009 04:30 PM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM


All times are GMT. The time now is 09:51 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.