Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Idle problems
Reply
 
LinkBack Thread Tools Display Modes
Old 29 Jan 2012, 10:11 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Location: Australia
Posts: 3
Idle problems

Hi I have a 1992 wrx and lately when i have tried to start my car it wont idle until the engine is warm enough to not stall itself, then when it's at idle and accelerated the revs drops and the car will stall itself. When sitting at idle for about 5 minutes the engine will then work normal and not stall when accelerated. Need help on what it might be. Any help would be greatly appreciated
Offline   Reply With Quote
Old 29 Jan 2012, 10:30 AM   #2 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Idle problems

Clean idle air control valve and check coolant temp sensor
Offline   Reply With Quote
Old 29 Jan 2012, 04:35 PM   #3 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Idle problems

check maf and 02 sensor aswell..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 06 Feb 2012, 04:46 AM   #4 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Location: Australia
Posts: 3
Re: Idle problems

Thanks ill give these things a go and tell you how i went
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! IDLE PROBLEMS dahashman Engine Bay 14 05 Jun 2009 06:35 PM
boost and idle problems d6nyb Engine Bay 5 17 Nov 2007 11:26 AM
Odd Idle when hot WAYNE WRX Engine Bay 3 12 Oct 2007 07:41 PM
idle all over??? andyd Engine Bay 4 10 Jan 2007 09:38 PM
Idle problems! pot1175 Technical General 13 07 Feb 2006 09:04 AM


All times are GMT. The time now is 10:18 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.