Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

My revs wont sit on 1,000 help!!!!
Reply
 
LinkBack Thread Tools Display Modes
Old 03 Oct 2011, 09:39 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Oct 2011
Posts: 2
My revs wont sit on 1,000 help!!!!

I have a subaru impreza 1995 that i recenty bought, it hasnt been on the road for 2 yrs as the previous owner was only using it as a project car, i got a mechanic to check it own he said car was still in fine condition, however recently everytime i drive and i come to an intersection once i put the clutch in to put the car in neutral and come to a complete stop, my revs sometimes sit on 2,000 and sometimes it goes up and down sounds like im reving the car, someonr said it could be the fuel injection? I really have no idea!! Anyone know what is could be and how much it would cost????
Offline   Reply With Quote
Old 03 Oct 2011, 09:50 AM   #2 (permalink)
Fresh Scooby
 
Join Date: Oct 2011
Posts: 2
Re: My revs wont sit on 1,000 help!!!!

Also when im driving and i let go of the accelorator the revs wont go down sometimes for like a few seconds the car drives itself!
Offline   Reply With Quote
Old 03 Oct 2011, 11:14 AM   #3 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: My revs wont sit on 1,000 help!!!!

Cleaning And Reattaching The IACV (Idle Air Control Valve) - NASIOC

Sounds like your iacv may need a clean
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 03 Oct 2011, 09:08 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Oct 2009
Location: banbury oxfordshire england
Posts: 10
Re: My revs wont sit on 1,000 help!!!!

have you had a listen under the bonnet with the engine running are there any new hissing noises,a possible air leak could give those symtoms
Offline   Reply With Quote
Old 13 Nov 2011, 09:14 AM   #5 (permalink)
Fresh Scooby
 
Join Date: Nov 2011
Posts: 3
Re: My revs wont sit on 1,000 help!!!!

i have the same problem mate. my subi has been sitting in the garage for a few months as i done some damage to the steering and suspension and today i let it run for awhile it was running really well until i gave the throttle a bit of the hit to kick the boost on so i could get everything moving in there and soon as i done that the reves wouldnt drop then it started rising and falling between 1-2000 revs.
Did you get yours fixed mate and wat did u figure out was wrong with it???
Offline   Reply With Quote
Old 09 Jan 2012, 12:37 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Feb 2011
Posts: 35
Re: My revs wont sit on 1,000 help!!!!

I had a similar probem with an old Scooby i had, when i pulled up at junctions and stopped the revs would dipp almost stalling, and sometimes it would idle high aswell. eventually, one day the car just stopped dead right the middle of football match traffic! and would not start up again. i had an auto electrician look at it who told me it was the clifford immobiliser locked up so he charged me 80 to remove it which still no difference. Eventually after a few more failed attempts at finding the fault, it turned out in the end to be a blown ECU which had to be replaced, so i decided to sell the car when i was quoted 400 to have this done! a few months later i saw the car on a website for sale and asked the new owner and he confirmed that when he replaced the ECU the car ran sweet as a nut.
Hope this helps!!! :O
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
revs problem Y8SEY Technical General 14 18 Nov 2010 11:46 AM
revs problem fatmick81 Engine Bay 4 15 Aug 2010 09:03 AM
Revs SailorBrads Engine Bay 4 19 Jul 2009 11:48 PM
high revs? kaa273 Technical General 3 02 Aug 2006 06:01 PM
cutting out at low revs then wont start for ages help plz robo Technical General 23 28 Mar 2005 11:28 PM


All times are GMT. The time now is 10:08 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.