Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

(x) Plate 2000 AWD "CHECK ENGINE" Light ?????
Reply
 
LinkBack Thread Tools Display Modes
Old 25 Sep 2011, 04:55 PM   #1 (permalink)
Fresh Scooby
 
SCO88Y's Avatar
 
Join Date: Apr 2011
Location: S-W Devon
Posts: 11
(x) Plate 2000 AWD "CHECK ENGINE" Light ?????

After 5 months of trouble free driving since i bought the car in April Thread LINK

Driving round town yesterday pulling away from a roundabout, Put my foot down and as soon as the turbo kicked in it spluttered like it was running on 2 cyclinders And CHECK ENGING warning came up on dash, When ever the boost came in it did the same thing, Pulled over turned engine off, Quick look under the bonnet, Couldent see anything wrong, Jumped back in started up, Light had gone out and seemed fine ? Did the same thing again today, But only round town ?

Thanks in advance.
Offline   Reply With Quote
Old 25 Sep 2011, 05:11 PM   #2 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

Get the code checked out and get back to us mate
Offline   Reply With Quote
Old 25 Sep 2011, 05:58 PM   #3 (permalink)
Fresh Scooby
 
SCO88Y's Avatar
 
Join Date: Apr 2011
Location: S-W Devon
Posts: 11
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

Quote:
Originally Posted by shambles View Post
Get the code checked out and get back to us mate
"Code"
Offline   Reply With Quote
Old 25 Sep 2011, 06:48 PM   #4 (permalink)
Bpm
Cool Scooby
 
Join Date: Jan 2008
Posts: 239
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

This happens to an Impreza owner at some point in time bass. The fault will store an error code which translates via a fault code reader, are u near "engine tuner" in plymouth? have it read and take it from their.
Offline   Reply With Quote
Old 25 Sep 2011, 07:50 PM   #5 (permalink)
Fresh Scooby
 
SCO88Y's Avatar
 
Join Date: Apr 2011
Location: S-W Devon
Posts: 11
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

Quote:
Originally Posted by Bpm View Post
This happens to an Impreza owner at some point in time bass. The fault will store an error code which translates via a fault code reader, are u near "engine tuner" in plymouth? have it read and take it from their.
Furry muff

There is a couple in Plymouth, Will have to get it looked at.


Thanks for that.

*The 1000 of fuel i've put through it since april isn't enough to spend on it then*
Offline   Reply With Quote
Old 26 Sep 2011, 09:44 AM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

02 or maf at a guess,pop n see Martyn
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 26 Sep 2011, 08:28 PM   #7 (permalink)
Fresh Scooby
 
SCO88Y's Avatar
 
Join Date: Apr 2011
Location: S-W Devon
Posts: 11
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

Quote:
Originally Posted by The Pilot View Post
02 or maf at a guess,pop n see Martyn
Soon as i get time i will
Offline   Reply With Quote
Old 10 Sep 2012, 01:02 PM   #8 (permalink)
Fresh Scooby
 
SCO88Y's Avatar
 
Join Date: Apr 2011
Location: S-W Devon
Posts: 11
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

'Update'

Since i posted this thread i have been to Alan Jefferys in Plymouth
Can't remember the fault code now but was told it was the "pressure sensor"
(see pic)

Bought a complete "Boost control unit" off good old ebay, All on the mounting bracket with 3 different parts on it, Every time the CHECK ENGINE light came on i would swap one of mine with one of the
ones from ebay, Then when the light came back on i would put mine back on, And replace another one, Having tryed this with all 3 i bought a new MAF sensor and still the CHECK ENGINE light comes
on !

Im sure it is something to do with the boost unit though, As sometimes when
accelerating hard in 2nd gear (Most noticable in that gear) The boost does not
"kick" in like normal, But lift the accelerator pedal and push it down again it boosts up like it should.

Am at a loss as to what it could be
Any ideas ???
Offline   Reply With Quote
Old 13 Sep 2012, 06:36 PM   #9 (permalink)
Scooby Fanatic
 
alunian's Avatar
 
Join Date: Aug 2010
Posts: 746
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

did you reset the ECU each time you swapped parts?

see this link on how to reset >>> ECU Reset... How many different methods are there???
Offline   Reply With Quote
Old 13 Sep 2012, 08:38 PM   #10 (permalink)
Fresh Scooby
 
SCO88Y's Avatar
 
Join Date: Apr 2011
Location: S-W Devon
Posts: 11
Re: (x) Plate 2000 AWD "CHECK ENGINE" Light ?????

Ah feck ! Never give it a thought
Will av to try again doing that each time, Fingers crossed i might find out which
one it is this time

Thanks for that fella
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine "Flash" - half second!?? jtanner Engine Bay 2 09 Sep 2008 11:54 AM
"check engine" light on dash The Highlander Engine Bay 6 02 Jun 2006 09:30 PM


All times are GMT. The time now is 10:25 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.