Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Impreza sportwagon 2.0L GX AWD - 51 Plate
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Mar 2011, 01:33 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Location: Wakefield, UK
Posts: 6
Impreza sportwagon 2.0L GX AWD - 51 Plate

Hello everyone.

Iíve got a problem with my car and hoping someone can help on here. The car is a 51 plate impreza estate 2.0L GX.

It has got an Idle speed control malfunction error on it and im struggling to find out what I need to do to solve it (without taking it to subaru). The idle speed control valve has been cleaned a few times but no joy.

The engine management light is now stuck on. The symptoms are losing all revs when I put the clutch in and it nearly stalling, varying tick over speed when stood still, slightly missing / losing power when setting off and generally running very rough with less power. The engine management light has been coming on and off and when it is off it runs perfect. I can get a second hand idle control valve for £60 but my garage advised me not to as it may not be that causing the problems..

Any suggestions to solve this problem would be great.

Many thanks in advance, Stu.

Ps. For anyone looking for a lambda / oxygen sensor or knock sensor for a 51 plate impreza 2.0L GX. I got a universal lambda sensor from Woodlesford motor spares in Leeds for about £80 and that worked fine. I got a knock sensor off a guy on eBay for about £60 and that work fine as well. Knock sensor part number is 22060-AA070.
Offline   Reply With Quote
Old 14 Mar 2011, 01:48 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Impreza sportwagon 2.0L GX AWD - 51 Plate

when you cleaned the IACV did you replace/Check the gasket ?
even if its leaking a bit the idle will be all over.
hth
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 14 Mar 2011, 02:53 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Location: Wakefield, UK
Posts: 6
Re: Impreza sportwagon 2.0L GX AWD - 51 Plate

Did not replace the gasket but it seemed ok. Think ill get a new one though, do you know if its a subaru only part? Any other ideas much appreciated? It runs perfect when the engine management light has been cleared or goes off.

Many thanks for the reply!!

Stu.
Offline   Reply With Quote
Old 23 Mar 2011, 03:07 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Location: Wakefield, UK
Posts: 6
Re: Impreza sportwagon 2.0L GX AWD - 51 Plate

I have been in contact with Subaru and the non-turbo models do not have an idle speed control gasket. The idle speed control valve slots in (to I don’t know what, please excuse my lack of knowledge) to something using a rubber ‘O’ ring. Does anyone know if this ‘O’ ring could be causing the problems and is worth replacing? Subaru don’t stock them but I’ll be able to get one from somewhere im sure.

Any comments or advice would be great! Many thanks.

Just for anyone who’s looking, like I was when I needed them. Part numbers for lambda / oxygen sensors. Front – 22641AA100, Rear – 22690AA540.
Offline   Reply With Quote
Old 24 Mar 2011, 09:30 AM   #5 (permalink)
Regular Scooby
 
gxwagon's Avatar
 
Join Date: Sep 2010
Location: Southampton
Posts: 170
Re: Impreza sportwagon 2.0L GX AWD - 51 Plate

I have the same car as you and my engine light kept coming on every so often had a check done at hiQ and they said it was the idle air control valve but only Subaru do them around 430pounds. Luckily I kicked up a fuss and they replaced it for free but after a brand new one was fitted the light would still come in...!! I had taken it to subaru before whenit wasin warranty and they said not to worry about it(hence when I found out wat it was,I wasn't happy).
Now this is the strange thing I had a new blueprint clutch put in the other day as mine was slipping( 439pounds) and the light hasn't come on once. I asked the mechanic if the new clutch would make the light come on and he said no but maybe it's a big coincidence. Anyway hope it helps mate
Offline   Reply With Quote
Old 28 Mar 2011, 08:51 AM   #6 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Location: Wakefield, UK
Posts: 6
Re: Impreza sportwagon 2.0L GX AWD - 51 Plate

Thanks for the reply i'll certainly bare that in mind about the clutch. Getting it plugged in again this week so hopefully might get to the bottom of the problem.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:33 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.