Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Engine Bay

Subaru Impreza Forum

Cel on causing issues.
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Feb 2011, 05:23 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2009
Location: Central CT
Posts: 23
Cel on causing issues.

Hey all, I have a 98 impreza L model. My check engine light came on a while back and threw the code P0440. It is just a general code that says Evaporative Emission Control. Also it is had to put gas into, the pump keeps shutting off unless you pump slow. I have heard these may be related. The code will come on and off randomly. Has Anyone had this problem before, if so what should i replace to fix it. Any help will be greatly appreciated Thanks
__________________
98 Impreza L AWD, 2.2Liter
Offline   Reply With Quote
Old 15 Feb 2011, 07:37 AM   #2 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: Cel on causing issues.

Quote:
Originally Posted by Chip682 View Post
Hey all, I have a 98 impreza L model. My check engine light came on a while back and threw the code P0440. It is just a general code that says Evaporative Emission Control. Also it is had to put gas into, the pump keeps shutting off unless you pump slow. I have heard these may be related. The code will come on and off randomly. Has Anyone had this problem before, if so what should i replace to fix it. Any help will be greatly appreciated Thanks
Not sure, but isnt that something to do with the charcoal cannister??
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Old 16 Feb 2011, 04:40 PM   #3 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Cel on causing issues.

As above ^ you should check the vacuum hoses on it and check that the hoses connected and not blocked!
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 16 Feb 2011 at 04:42 PM.
Offline   Reply With Quote
Old 16 Feb 2011, 05:10 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Apr 2009
Location: Central CT
Posts: 23
Re: Cel on causing issues.

Yeah i did check the hoses and they are in good shape. I think i may have found the prob though. Under the back of the car there is a small square looking box called a VENT VALVE. This has a good sized crack in it so i suspect that will be the prob
__________________
98 Impreza L AWD, 2.2Liter
Offline   Reply With Quote
Old 19 Feb 2011, 12:40 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Apr 2009
Location: Central CT
Posts: 23
Re: Cel on causing issues.

Well I just thought i would say that i got this problem sorted out. I replaced the canister vent valve as mentioned above and success!! problem soved, pumped 30 dollars of fuel without a problem
__________________
98 Impreza L AWD, 2.2Liter
Offline   Reply With Quote
Old 19 Feb 2011, 05:31 PM   #6 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: Cel on causing issues.

Quote:
Originally Posted by Chip682 View Post
Well I just thought i would say that i got this problem sorted out. I replaced the canister vent valve as mentioned above and success!! problem soved, pumped 30 dollars of fuel without a problem
Excellent news.
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
minor issues after 1st week of ownership jdm28 Subaru Impreza Discussions 9 18 Mar 2010 12:52 PM
Brake issues force Corser to play safe News_Bot Superbike News 0 29 Sep 2009 09:30 AM
Brakes issues force Corser to play safe News_Bot Superbike News 0 29 Sep 2009 08:50 AM
Valencia 'solving minor issues' ahead of F1 bow. News_Bot Formula News 0 14 Aug 2008 11:00 AM
Suzuki: Engine issues sorted. News_Bot Rally News 0 23 Mar 2008 12:10 PM


All times are GMT. The time now is 08:59 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.