Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

Help!
Reply
 
LinkBack Thread Tools Display Modes
Old 17 Jan 2011, 01:16 PM   #1 (permalink)
Fresh Scooby
 
RA_L's Avatar
 
Join Date: Jan 2011
Location: Wiltshire!
Posts: 30
Help!

Hi I wonder if anyone can shed a bit of light for me please?

When looking at the manifold on my car, next to it there is a heat wrapped cable with 3/4 wires in it that has been dangling on the manifold and the red wire has burnt through.

I have looked, and looked at a wiring diagram and I cannot make head nor tail of it, does anybody know what this might be for? I suspect given location and heat wrapping that it is certainly important... Nightmare!

Thanks!
__________________
'Maturity is a bitter disappointment for which no remedy exists, unless laughter can be said to remedy anything..'
Offline   Reply With Quote
Old 17 Jan 2011, 03:52 PM   #2 (permalink)
Young Scooby
 
Join Date: Oct 2010
Location: South London
Posts: 94
Re: Help!

If is a classic shape (not sure if the same with later models) you have a o2/lambda sensor on the manifold, it screws in on the drivers side, just beneath the rocker covers. they have three wires, which tend to have wrap round them and if you follow the cable it plugs in just underneath the power steering pump. it could be this.
Offline   Reply With Quote
Old 21 Jan 2011, 11:39 AM   #3 (permalink)
Fresh Scooby
 
RA_L's Avatar
 
Join Date: Jan 2011
Location: Wiltshire!
Posts: 30
Re: Help!

Hiya

Thanks for this. I'm not sure it is.. Lol after fishing around under the car, I can't find the lambda (poor scoob is running like a bag of dirty pants) ugh. I'm in such a mess, I might give up and throw her in a garage - trailer her there!
__________________
'Maturity is a bitter disappointment for which no remedy exists, unless laughter can be said to remedy anything..'
Offline   Reply With Quote
Old 21 Jan 2011, 01:19 PM   #4 (permalink)
Young Scooby
 
Join Date: Oct 2010
Location: South London
Posts: 94
Re: Help!

You should have one there somewhere, could be one of the reasons for the bad running... Gave you the wrong place for the connections tho..(sorry) It's underneath the header tank for the radiatior, not the power stearing pump. But as you say, it might not be that. Maybe someone else here may have an idea.
Offline   Reply With Quote
Old 21 Jan 2011, 02:17 PM   #5 (permalink)
Fresh Scooby
 
RA_L's Avatar
 
Join Date: Jan 2011
Location: Wiltshire!
Posts: 30
Re: Help!

Ahhhh that rings a bell actually, at the moment I've hooked it up over my induction kit braket. I suspect you're right - although I wasn't expecting to have a lambda because I had a FMI with the intention of replacing ECU and remapping (then pulled it out of garage) so I think they's said they'd taken it off, and there is a blanking plate. I wonder if they've just kind of thrown it back in the bay? Surely having it not hooked up correctly would explain the terrible running? It does run rich sometimes. Grrr LOL
__________________
'Maturity is a bitter disappointment for which no remedy exists, unless laughter can be said to remedy anything..'
Offline   Reply With Quote
Old 23 Jan 2011, 02:53 PM   #6 (permalink)
Fresh Scooby
 
RA_L's Avatar
 
Join Date: Jan 2011
Location: Wiltshire!
Posts: 30
Re: Help!

You were quite right wilsbrough, lambda sensor it was!
__________________
'Maturity is a bitter disappointment for which no remedy exists, unless laughter can be said to remedy anything..'
Offline   Reply With Quote
Old 23 Jan 2011, 07:54 PM   #7 (permalink)
Young Scooby
 
Join Date: Oct 2010
Location: South London
Posts: 94
Re: Help!

Glad you've solved one of the probs. I've just replaced mine. Getting the old one out was fun tho, i had to get a welding torch to it to get it off, which left half the thread in the manifold....!Had to re-thread the manifold....Yay, old cars eh? My girlfriend is becoming a subaru widow I was toying with a cheaper one but decided not to chance it and buy a genuine subaru one. Not cheap at 150... But it made the car run much better. Remember to re-set the ecu once you've done it.
Offline   Reply With Quote
Old 23 Jan 2011, 08:11 PM   #8 (permalink)
Fresh Scooby
 
RA_L's Avatar
 
Join Date: Jan 2011
Location: Wiltshire!
Posts: 30
Re: Help!

Yeah we thought we were going to have to replace it, but the OH thinks it can be saved with a bit of cutting and wrapping. Mechanic left it dangling after fitting exhaust... Grrr.

As for the g/friend I'm surprised she's not into it... Ours was a belated Xmas present really to my boyfriend (but I find myself just as obsessed)

Reset ECU - I've read the threads on this and think I understand - but do you have to disconnect the battery's neg to finish the process? I have found conflicting views on this?

Thanks!
__________________
'Maturity is a bitter disappointment for which no remedy exists, unless laughter can be said to remedy anything..'
Offline   Reply With Quote
Old 23 Jan 2011, 10:37 PM   #9 (permalink)
Young Scooby
 
Join Date: Oct 2010
Location: South London
Posts: 94
Re: Help!

No, she really does not like it. I had to put the baffle into the exhaust cos it was 'too loud n every one's looking...!' Also when i'm driving, apparently it makes her really stressed, she thinks i'm not aware of whats going on around me.(Not true i add..) Coming from the girl who told me she went the wrong way down a 3 lane duel carriageway, and only realised when all the cars were coming towards her, then had to do a 3 point turn in front of them... I guess i'm a petrolhead n she's not. Anyhow i found this method works for me. Main Heading Goes Here
Offline   Reply With Quote
Old 31 Jan 2011, 04:45 PM   #10 (permalink)
Fresh Scooby
 
RA_L's Avatar
 
Join Date: Jan 2011
Location: Wiltshire!
Posts: 30
Re: Help!

Ah smashing lol thanks for that.

I think we're nearly straight with it now - just a bit of hose shopping this week and fingers crossed we sussed it. Defo going to look at bodging lambda for now. My friend reckons there's a problem with an earth connection to something or another lol having problems intermittently with starting the dam thing - some days fine, so don't think it's starting motor... Really should have thought about what we were getting into, I console myself with the thought that new cars can also be problematic.. I could have had a nice, new VW for the money LOL (no shooting allowed - I love the Scoob really)


I know what the Gfriend means, the manifold with de cat and blitz back box is insanely noisy (and stops some of the grouchier neighbours from making eye contact bah humbug) am looking for a baffle in the hope it might make it sound a bit less 'raw' it's much more growly than I thought it would be! And the 3 lane thing is brilliant - I am the only biker I know who cannot pull a U-turn.. And had to re-do my CBT - Oh the shame!!
__________________
'Maturity is a bitter disappointment for which no remedy exists, unless laughter can be said to remedy anything..'
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:43 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.