Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

96 impreza NO GO....
Reply
 
LinkBack Thread Tools Display Modes
Old 26 Apr 2010, 05:19 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 4
96 impreza NO GO....

Hello there, am new to the forum and on the scrounge for info already!!!.. recently bought my first impreza, been great for a couple of monthes, then yesterday started missing, then conked out and wuld start if you left it, then conk out again and now just cranking over. Read codes and got two codes 11 think is crankshaft sensor and 22 knock sensor i think, but i don't know how old codes are, can you clear them if yo can't start motor? havn't got much paper work or info yet..Havn,t got spark, but have got fuel,well pumps going when you crank,so i take it the crankshaft sensor is o.k,put a logic probe on and getting a neg pulse when cranking and if you unplug it you get no pump, had code before i unplugged.....was wondering wether the ignition amplifier is common fault or not?? and wonderd wether anyone has got a engine ecu wiring diagram or ecu pin out?? so i can try prove some more things out, checked out very dodgy cat 1 immobiliser but not that.

Thanks everyone.
Offline   Reply With Quote
Old 26 Apr 2010, 05:48 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: 96 impreza NO GO....

Crank sensor would cause a none start
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 27 Apr 2010, 06:08 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 4
Re: 96 impreza NO GO....

Thanks, will try another crankshaft sensor the next few days, are they pricey??

cheers
Offline   Reply With Quote
Old 27 Apr 2010, 08:12 AM   #4 (permalink)
Senior Scooby
 
scoobymike79's Avatar
 
Join Date: Sep 2009
Location: Lincolnshire
Posts: 1,730
Re: 96 impreza NO GO....

Usually cost from around 30 upwards, might be worth checking ebay
__________________
"Straight roads are for fast cars, turns are for fast drivers." -Colin McRae
Offline   Reply With Quote
Old 27 Apr 2010, 12:07 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Apr 2010
Posts: 4
Re: 96 impreza NO GO....

Not sure if it is crank sensor after looking at it today, borrowed picoscope and getting a good waveform on crankshaft sensor, and tried a tester/simulator (thank god for good friends) on c/s sensor harness,and still no go, putting pump on though as it was originally, gonna try work out what waveform should come out of igniter/amplifier next when i get time.

thanks guys for ya time.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Impreza Applied Model/Engine Codes 2002pete Technical General 40 02 Jul 2015 06:22 PM
Info: Subaru Engines and Conversion Principles djquest Modifications - Tips and Tricks 10 19 Dec 2011 12:16 PM
Big Value from Final-Edition Impreza WRX Mezza World Wide Automotive - News / Discussions 5 06 Jul 2007 03:26 PM


All times are GMT. The time now is 08:01 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.