Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

help help 1993 impreza ECU
Reply
 
LinkBack Thread Tools Display Modes
Old 20 Jan 2010, 11:49 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Posts: 12
help help 1993 impreza ECU

hey guys,
i just finished putting a 2.2 liberty motor into my original 1.8 impreza wagon,
and we put it all back together and forgot to put the earth back on.
since there was no power from the fuel pump or anything we straight wired it to the battery to pump fuel through till we relised wat we've done.
we then put the earth back on.
And it still wont start, im just wondering if anyone knows if we might have blown the ecu?
the car sounds like it wants to starts and is trying to by just kicking but just wont start.
we are all out of ideas of wat it could be. . . is there anyone out there that has done this before that could lend us a few details we may have missed? we are looking around for an ecu now. but we arent sure whether mine is still working or not.
Is there any way we can test it?
well i really hope someone can help me.
thanks heaps everyone
Offline   Reply With Quote
Old 21 Jan 2010, 12:49 AM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: help help 1993 impreza ECU

Did you get an Ecu for the 2.2 engine and all wiring harnesses and all that? is the engine turning over? or dead completly? is their fuel going to injectors? is their spark? is any fuse's or relays blown? check battery? timing belt ok? are plugs ok and gapped right? are HT Leads or coilpacks fitted correctly? also could try a similar Ecu to see if it works...........
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 21 Jan 2010 at 12:51 AM.
Offline   Reply With Quote
Old 21 Jan 2010, 10:24 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Posts: 12
Re: help help 1993 impreza ECU

yeh we did get all the wiring and that but we were trying to avoid swapping everything over.. if that was an option. yeh the engine is turning over and decides to backfire every now and again.. but just wont start. yeh theres fuel going through,yeh theres a spark, no fuses or relays blown. battery is brand new just before the old motor died. timing belt done about 3months ago. plugs are fine .
dont know about the last few things.
but yeh can i just plug in a friends impreza and if it starts it should just be the ecu?
Thanks heaps i REALLY appreciate the advice and quick reply.

haha just asked dad about what else to write and he added that we drove the liberty into the yard. and was running fine
Offline   Reply With Quote
Old 21 Jan 2010, 10:35 AM   #4 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: help help 1993 impreza ECU

Havent you swapped all the wiring and loom over ?
If so your old loom may not run it as the pins on the ecu arent the same.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 21 Jan 2010, 10:37 AM   #5 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Posts: 12
Re: help help 1993 impreza ECU

nah i havent swapped it all over cause we just swapped the manifolds..
Was that a bad idea?
Offline   Reply With Quote
Old 21 Jan 2010, 11:03 AM   #6 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: help help 1993 impreza ECU

oh thats ok you didnt explain that lol
Crank sensor then
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 21 Jan 2010, 10:34 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Posts: 12
Re: help help 1993 impreza ECU

ok ill check that out today and let u know how i go.

once again im very appreciative of all the help .
Offline   Reply With Quote
Old 22 Jan 2010, 12:52 AM   #8 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: help help 1993 impreza ECU

Quote:
Originally Posted by 93impreza View Post
yeh the engine is turning over and decides to backfire every now and again.. but just wont start.
By this I'am thinking with the timing belt you fitted were all the alignment marks correct on the 4 camshaft sprockets (DOHC) and crankshaft sprocket where they all alligned up right and belt tensioned right? also might be a vacuum leak at the trottle body or inlet manifold as you were at that and also check the hoses round these for vacuum leaks or the HT firing sequence might be wrong as in you put the wrong lead on a spark plug or coilpack on wrong spark plug if you have coilpacks rather than the HT Leads and might also be a blocked fuel injector hope it helps OR Iam wrong and Brett is right with crankshaft sensor being faulty
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 22 Jan 2010 at 01:03 AM.
Offline   Reply With Quote
Old 27 Jan 2010, 05:30 AM   #9 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Posts: 12
Re: help help 1993 impreza ECU

thanks everyone for your help.
it was ...... the Crank sensor
its still running a bit ruff now.
would anyone know if it might just be the computer adjusting to the new motor? or am i better off taking it to my local subaru place.
cause its just like mising around the 2000 revs.
thanks again for all the help
really appreciate it.
Offline   Reply With Quote
Old 21 Feb 2010, 09:02 PM   #10 (permalink)
Fresh Scooby
 
Join Date: Nov 2009
Posts: 12
Re: help help 1993 impreza ECU

Hello again everyone,
After a week or two of trying to sort out wats going on now .. ive come to another problem...
When we changed moved the crank angle sensor she finally started, but now she wont idle when cold, wont really start unless i accelerate a little bit,but when it does start it wouldnt idle for any more then 5 seconds.
After about 4 minutes of holding the accelerator on partially it gets warm, but sometimes will stall still if i have to stop at a stop sign for more then 5 seconds.
It also seems like it helps idle when i have the A/c on.
And Ever since the motor has been in it is using about 15L per 100kms.
Also it sorta jults/jumps every now and a again.. and sounds like its choking on fuel cause it will (feel like) its blocking up then i take my foot off the accelerator for a second then back on and it will go again..(seems like it only really does this on hills,up or down)
Well i hope someone out there can help me out.
we are thinking about resetting the ecu? cause its still running the old impreza one, because we didnt change the wiring harness as said above.
Cant wait till she goes with no hassles
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Impreza Applied Model/Engine Codes 2002pete Technical General 40 02 Jul 2015 06:22 PM
Info: Subaru Engines and Conversion Principles djquest Modifications - Tips and Tricks 10 19 Dec 2011 12:16 PM
Immobiliser problems in a Subaru Impreza 1993 sarah Electrical (Including ICE) 2 30 May 2009 09:03 AM


All times are GMT. The time now is 11:21 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.