Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

? common electrical glitch
Reply
 
LinkBack Thread Tools Display Modes
Old 07 Jan 2010, 09:29 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Posts: 4
Question ? common electrical glitch

working on wife's 2000 subaru impreza rs coupe. has no dome light, no stereo power, no cruise now, sunroof intermittent.when i run an independant power to dome light it will illuminate, and the stereo will fire up. i have accessed the drivers door jam switch also. when i put 12 volt external power to, it ,it will short on either terminal on the switch. is this maybe just a ground interupter switch. its got me. the cuise button will light up but it won't engage. any ideas. thanx.
Offline   Reply With Quote
Old 07 Jan 2010, 10:55 PM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: ? common electrical glitch

Check fuses, faulty relays and ground wires hope it helps hate electrics
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 08 Jan 2010, 09:42 AM   #3 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: ? common electrical glitch

The cruise issue could be a faulty brake switch or clutch switch
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 08 Jan 2010, 01:49 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Posts: 4
Re: ? common electrical glitch

thanx ,i think i've read something about that, in relation to an automatic though?
Offline   Reply With Quote
Old 08 Jan 2010, 02:42 PM   #5 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: ? common electrical glitch

there will still have to be a brake pedal switch, it will be a double pole type as it has to make/break the brake lights too, if u pull 1 plug off and bridge the connectors u might get the brake lights on all the time if so put that back and pull the other plug off and bridge the connectors again, this will tell the cruise control you havent pressed the brake pedal as say its ok to engage cruise control, now test the cruise control out,
If this works you know the switch needs replacing,

THIS IS TO TEST IT ONLY NOT A REPAIR,
dont want anyone driving round like this and saying I said to do it lol.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 08 Jan 2010, 02:46 PM   #6 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: ? common electrical glitch

It still sounds like a fuse 9 under the bonnet, and a sunroof motor issue maybe
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 09 Jan 2010, 02:47 AM   #7 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Posts: 4
Re: ? common electrical glitch

whew got half the troubles licked. faulty dome light switch killed power to stereo as well. sunroof has a common circuit seems ok now. next i'll tackle that cruise. got another electrical glitch. aftermarket remote start won't stay programmed. powerstart. thanx for your suggestions.
Offline   Reply With Quote
Old 09 Jan 2010, 09:05 AM   #8 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: ? common electrical glitch

what was the dome light & stereo fault ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 09 Jan 2010, 03:14 PM   #9 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Posts: 4
Re: ? common electrical glitch

common power source b/t the two. dome light switch fried killing power to the stereo as well. according to the schematics the sun roof has a common wire as well. but that might have been an unrelated issue. i'm not sure. my wife now says the sun roof has been intermittent for quite a while.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FOTA reaches 'common view' on F1 budget cap crisis News_Bot Formula News 0 22 May 2009 06:40 PM
FOTA reaches 'common view' on budget cap crisis News_Bot Formula News 0 22 May 2009 05:40 PM
Trulli: 'Common sense' and honesty ended in justice News_Bot Formula News 0 02 Apr 2009 04:50 PM
Electrical glitch hampers PKV. News_Bot Champ Car News 0 25 Jan 2007 04:10 PM


All times are GMT. The time now is 03:21 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.