Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

dash light and fog lights have gone off
Reply
 
LinkBack Thread Tools Display Modes
Old 25 Dec 2009, 02:42 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Dec 2009
Posts: 7
dash light and fog lights have gone off

hi i am new to the forum and have big problems i was on my way home last night when i noticed the dash lights has all gone off so had the front and back fog lights and rear lights have looked at fuses and they all seem fine please help someone PLZ?????
Offline   Reply With Quote
Old 25 Dec 2009, 02:57 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

what car is it on ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 25 Dec 2009, 02:58 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Dec 2009
Posts: 7
Re: dash light and fog lights have gone off

subaru impreza sport p reg 1997
Offline   Reply With Quote
Old 25 Dec 2009, 03:09 PM   #4 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

Which fuses have you checked ?
There is a set behind the coin tray on the lower part of the dash to the right of the steering wheel,
Fuse 9(2nd row down and 2nd fuse from the left) is ur problem runs the dash lights and relays for the fogs.
Merry Christmas.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 25 Dec 2009, 03:17 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Dec 2009
Posts: 7
Re: dash light and fog lights have gone off

just checked that there is a 10amp fuse in and it fine ??????
Offline   Reply With Quote
Old 25 Dec 2009, 04:08 PM   #6 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

Sorry then I cant help, Have you gone thru all the fuses with a known good fuse?
Bit weird you have lost Certain circuits that are covered by said fuse too.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 28 Dec 2009, 10:42 AM   #7 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

Any news of your problem chap ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 28 Dec 2009, 01:13 PM   #8 (permalink)
Fresh Scooby
 
Join Date: Dec 2009
Posts: 7
Re: dash light and fog lights have gone off

nope still have the smae problems fuses look ok and all wire and coinnections loook fine behind the steering no loose connections witch points towards a earth problem me thinks
Offline   Reply With Quote
Old 28 Dec 2009, 01:53 PM   #9 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

Have you got 12v on 1 side of the fuse ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 28 Dec 2009, 01:55 PM   #10 (permalink)
Fresh Scooby
 
Join Date: Dec 2009
Posts: 7
Re: dash light and fog lights have gone off

witch fuse is it second row down second from the left
thanks
Offline   Reply With Quote
Old 21 Jan 2010, 06:40 PM   #11 (permalink)
Young Scooby
 
daviesbike's Avatar
 
Join Date: Jan 2010
Location: N wales
Posts: 53
Re: dash light and fog lights have gone off

hi im new to the site and im having an identical problem and i need help asap,

all fuses are fine in the drivers foot well as to are the ones under the bonnet, fogs dont work side lights dont work and all dash lights are off, mine is a 1997 wrx

can any one help as i dont want to get pulled over ?

thanks
Offline   Reply With Quote
Old 21 Jan 2010, 06:49 PM   #12 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

does everything else work ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 21 Jan 2010, 07:40 PM   #13 (permalink)
Fresh Scooby
 
Join Date: Dec 2009
Posts: 7
Re: dash light and fog lights have gone off

yes they do
Offline   Reply With Quote
Old 21 Jan 2010, 07:40 PM   #14 (permalink)
Young Scooby
 
daviesbike's Avatar
 
Join Date: Jan 2010
Location: N wales
Posts: 53
Re: dash light and fog lights have gone off

well the things that dont work are the fogs the side lights ie the little side lights and the rear side lights, when you press the brakes they light up but with the lights on they are not, the dash bord is pitch black only thing working on there is when i put main beam on it lights blue and the de mister for the rear lights up. apart from that i got only dipped and main beam and brake lights only when peddle is pressed though,

what can i do.... i have checked all fuses in the drivers side all are fine, and under the bonnet the same, is there another fuse box im missing maybe ?

the fuse boxes i checked are the one on the right hand side under the bonnet and the one on the drivers side foot well to the right, ?

many thanks
Offline   Reply With Quote
Old 21 Jan 2010, 07:50 PM   #15 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: dash light and fog lights have gone off

This shows the way the power is fed to the lights etc, if you’re sure the fuses are ok then you need a 12v tester,

It is always useful to test or prove ur tester on a known 12v supply

You need to find out if there is 12v feeding these fuses, you need to pull the fuse out and put 1 of the wires for the tester or a home made bulb with leads on will work for this test on a good earth/ground, door hinges/Ignition barrel can be good for this,
You then put the other end of ur test lead on to 1 side of where you pulled the fuse from if it does say 12v or the bulb doesn’t light up try the other side of the fuse,
If you still cant find 12v you need to start looking at the fuses that supply power to that board (the attachment may help)

Now if you do get 12v or your bulb lights up you have proved you have 12v and imo your then looking for a broken earth.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.

Last edited by bugeye_bob; 06 Jun 2010 at 06:42 AM.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:06 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.