Subaru Impreza Forum - WRX STI Rally Performance Tuning

Subaru Impreza Forum - WRX STI Rally Performance Tuning (http://www.subaru-impreza.org/forum/)
-   Electrical (Including ICE) (http://www.subaru-impreza.org/forum/electrical-including-ice/)
-   -   Need some help (http://www.subaru-impreza.org/forum/electrical-including-ice/80129-need-some-help.html)

stiimpreza1984 21 Oct 2009 01:01 AM

Need some help
 
Working on a 1999 Turbo impreza at the moment strangest thing its an intermittent fault hope ye guys can help the battery goes dead the odd time changed the battery 2mths ago with a new one. Does not seem to be alternator cause it seems to be charging ok with load checked all lights thinking they staying on after car shut down everything goes off and checked the most possibilities any 1 have an idea what it could be pulling my hair out from it wrecking my head it will not defeat me:lol::lol: Thanks

bugeye_bob 21 Oct 2009 06:57 AM

Re: Need some help
 
Can you get hold of a clamp on amp meter? then pop that over the live wires at the fuse box 1 by 1 it will tell you which wires are drawing the most current, this will help you work out whats draining your battery,
Id unplug the fuse/relay for the heated rear window for the 1st thing to try if you dont have a boot of ICE.
hth

2002pete 21 Oct 2009 07:09 AM

Re: Need some help
 
Hi Darren, i wish i could help. :( Did you check your grounds and you power wires, make sure you are not shorting. "loose or corroded"

uk dave 21 Oct 2009 01:57 PM

Re: Need some help
 
Usually alarms in my experience

stiimpreza1984 22 Oct 2009 12:44 AM

Re: Need some help
 
Thanks guys for the replies really stuck on this one checked the earths and for wires corroded alls good he dont have an alarm so that cancels that out so il try that next Brett a bag of nightmares really:(

woodo 22 Oct 2009 08:13 AM

Re: Need some help
 
have you checked starter motor permanent live? this one came loose on mine and was arking onto earth, once tightened battery never went flat again

stiimpreza1984 22 Oct 2009 06:52 PM

Re: Need some help
 
Quote:

Originally Posted by woodo (Post 346295)
have you checked starter motor permanent live? this one came loose on mine and was arking onto earth, once tightened battery never went flat again

Il check that to cheers


All times are GMT. The time now is 02:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177