Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

Front screen washer not working
Reply
 
LinkBack Thread Tools Display Modes
Old 23 Aug 2009, 07:46 AM   #1 (permalink)
Scooby Fanatic
 
MalcB's Avatar
 
Join Date: Aug 2009
Location: Taunton
Posts: 779
Front screen washer not working

Just bought an 02 WRX and the front screen washer doesn't work. Rear one is OK. I assume both are the same fused link?

Any idea's please
Offline   Reply With Quote
Old 23 Aug 2009, 04:18 PM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Front screen washer not working

Cant remember if the front and rear share the same fuse but I would check anyway to see if any fuses blown if not its more than likely a block in the hose or the washer tank motor.............
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 23 Aug 2009, 04:37 PM   #3 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: Front screen washer not working

Quote:
Originally Posted by MalcB View Post
Just bought an 02 WRX and the front screen washer doesn't work. Rear one is OK. I assume both are the same fused link?

Any idea's please
The front screen washer/wiper is number 15 on the fuse panel with a 30A fuse and the rear washer/wiper is number 14 with a 10A fuse.
__________________
Pete.

Offline   Reply With Quote
Old 23 Aug 2009, 06:00 PM   #4 (permalink)
Scooby Fanatic
 
MalcB's Avatar
 
Join Date: Aug 2009
Location: Taunton
Posts: 779
Re: Front screen washer not working

Thanks for the replies. Wipers work Ok. I will check fuses, pump motor and blockage tomorrow when I get 10 minutes.
Offline   Reply With Quote
Old 24 Aug 2009, 09:07 AM   #5 (permalink)
Scooby Fanatic
 
MalcB's Avatar
 
Join Date: Aug 2009
Location: Taunton
Posts: 779
Re: Front screen washer not working

Everything is working OK !!! It was me being a Tw@t. I was pulling the stalk towards me instead of pressing the button on the end.

Old habits die hard.
Offline   Reply With Quote
Old 24 Aug 2009, 10:27 AM   #6 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: Front screen washer not working

Glad you got it sorted.
__________________
Pete.

Offline   Reply With Quote
Old 24 Aug 2009, 01:17 PM   #7 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: Front screen washer not working

Quote:
Originally Posted by MalcB View Post
Everything is working OK !!! It was me being a Tw@t. I was pulling the stalk towards me instead of pressing the button on the end.

Old habits die hard.
Me being a bigger twat- when i got mine rang the garage where i had it from to say they werent working when i got home(garage were at wigan im in notts)they said book it into a scooby dealership an we`ll pay for it(thought were fair enough)so i thought i`ll just go bk out to car an check for sure................glad i realised i`d have felt a right looser at a subaru dealership...err it works fine sir.

Ya dont half feel a proper numpty though when ya realise lol.
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 25 Aug 2009, 09:24 PM   #8 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Front screen washer not working

Quote:
Originally Posted by MalcB View Post
Everything is working OK !!! It was me being a Tw@t. I was pulling the stalk towards me instead of pressing the button on the end.

Old habits die hard.
Happened to me too coming from Hondas you pull stalk toward you to operate the screen washer but didnt know this in my scoob dohhhhhh
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
front mount lag Tidgy Subaru Impreza Discussions 11 16 Jul 2007 06:40 PM
[LEXUS] INTRODUCING THE NEW LEXUS IS skylight World Wide Automotive - News / Discussions 0 18 Nov 2005 08:34 PM
NEW-LOOK AND CLASS-LEADING PERFORMANCE FOR ’06 FORESTER skylight General Chat - Anything about Anything 2 03 Aug 2005 05:05 PM
OUTSTANDING NEW ‘BOXER’ ENGINE FOR ’06 LEGACY RANGE skylight General Chat - Anything about Anything 3 03 Aug 2005 10:15 AM


All times are GMT. The time now is 09:04 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.