Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

major electric problem help !!!
Reply
 
LinkBack Thread Tools Display Modes
Old 01 May 2009, 08:56 PM   #1 (permalink)
Fresh Scooby
 
Join Date: May 2009
Posts: 2
major electric problem help !!!

i have recently had my subaru rebuilt and i have the following problems:
my fuel gauge does not work

my tail lights dont come on but all bulbs and fuses are fine aswell as other lights ok

my sunroof does not work
can anyone please help
Offline   Reply With Quote
Old 01 May 2009, 11:28 PM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: major electric problem help !!!

Quote:
Originally Posted by njberrie View Post
i have recently had my subaru rebuilt and i have the following problems:
1)my fuel gauge does not work

2)my tail lights dont come on but all bulbs and fuses are fine aswell as other lights ok

3)my sunroof does not work
can anyone please help
1 could be a faulty fuel sender unit or the float is stuck to end of the tank reading it an empty tank

2 Either bad connection, relay or earth.
3 Check the fuse or relay
Heres manual's to download will give you a good idea on troubleshooting Download PDF Subaru | PDFTown.com
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 01 May 2009 at 11:33 PM.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power loss Problem, Please help - maybe clutch djquest Technical General 23 20 Oct 2007 05:02 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM
Another problem...GRRRRRRR sjay72 Subaru Impreza Discussions 1 07 Feb 2007 11:29 PM
MY99 Turbo ignition problem M-Tech Engine Bay 7 27 Aug 2006 06:56 AM


All times are GMT. The time now is 11:15 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.