Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

Poor volume, very poor volume!
Reply
 
LinkBack Thread Tools Display Modes
Old 05 Mar 2009, 11:02 PM   #1 (permalink)
Fresh Scooby
 
Scoobynator2109's Avatar
 
Join Date: Jan 2009
Posts: 2
Unhappy Poor volume, very poor volume!

Got the 2008 impreza STi with the sat nav kit installed. Has anyone else found the audio quailty rather crap and VERY quite or is it just me. When hooked up to an iPod, full volume is just normal volume but you cant hear it over the noise of that 300hp power plant. would installing a extra amp impove this??
Offline   Reply With Quote
Old 06 Mar 2009, 10:46 AM   #2 (permalink)
Veteran Scooby
 
rikimaru's Avatar
 
Join Date: Aug 2006
Location: Sussex
Posts: 3,335
Re: Poor volume, very poor volume!

Can't help you with the Impreza i'm afraid, but I did have an'08 Legacy for a week in the summer and that stereo was crapola with a CD in it.

How high do you have your i-pod turned up? In my Impreza i find i have to have the volume almost up to full on the i-pod t hear it properly and then have the stereo on about 18-20(/50) and is absolutely fine, and that is in an RA.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:29 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.