Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

CEL-another question!
Reply
 
LinkBack Thread Tools Display Modes
Old 31 Jul 2008, 10:55 AM   #1 (permalink)
bmd
Cool Scooby
 
bmd's Avatar
 
Join Date: Apr 2007
Location: N.I.
Posts: 201
CEL-another question!

hi guys,
i know this topic has been discussed several times, but can i ask one final thing about the CEL light on my 2004 WRX?

i know the light came on last year when i fitted a decat system and removed the cats
i know a CELFIX will send a false reading to the ECU that knocks the light off, and although i bought one, i never got around to fitting it as i knew what the cause was (dumb, huh? )
However, i have now refitted the standard system, including lambda sensor, but the CEL light has stayed on; i have disconnected the battery overnight, no joy; i know there are ways to cancel out the light on classic shape, but how can i fix the one on my new age scoob?
do i need to take it to a 'specialist' who will no doubt charge silly money for a 5-minute plug-in service? the guy in kwikfit said if i drive it for a few days, the messages back to the ECU stating all is back to normal will eventually knock the light off; has anyone tried this?

thanks for any advice guys
billy
Offline   Reply With Quote
Old 31 Jul 2008, 12:55 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: CEL-another question!

Quote:
I have now refitted the standard system, including lambda sensor, but the CEL light has stayed on; i have disconnected the battery overnight, no joy
Wow billy. That is a good question. I'm sure Alyn Stockton would know the answer .

Telephone him mate.

Link: AS Performance - Rally Motorsport Specialists
__________________
Pete.

Offline   Reply With Quote
Old 31 Jul 2008, 01:04 PM   #3 (permalink)
bmd
Cool Scooby
 
bmd's Avatar
 
Join Date: Apr 2007
Location: N.I.
Posts: 201
Re: CEL-another question!

hi pete,
yeah just off the 'phone to alyn, he agreed that running the car for a few times should knock off the cel, so i'll try that and let you know how i get on;
hope all is well on the mainland with you guys
cheers
billy
Offline   Reply With Quote
Old 04 Aug 2008, 11:15 AM   #4 (permalink)
bmd
Cool Scooby
 
bmd's Avatar
 
Join Date: Apr 2007
Location: N.I.
Posts: 201
Re: CEL-another question!

right guys, just in case anyone needs to do this in future, i've driven the scooby for 3 days now since re-fitting the original exhaust system, and the CEL light stayed on; it appears the 'fault' is kept in the ECU memory until it is either fixed or re-set; i've just had it re-set (5 mins, 20!) and it is cleared and showing normal again...
hope this comes in handy for someone in the future;
thats the scoob off the road now, driving the cougar (!) and will be trying to sell the impreza again now that she's back to standard, so for less money ;
cheers
billy
Offline   Reply With Quote
Old 04 Aug 2008, 11:38 AM   #5 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: CEL-another question!

Quote:
just in case anyone needs to do this in future

Quote:
Originally Posted by bmd View Post
it appears the 'fault' is kept in the ECU memory until it is either fixed or re-set;
Thanks billy.

re-set. 5 mins = 20
__________________
Pete.

Offline   Reply With Quote
Old 04 Aug 2008, 11:57 AM   #6 (permalink)
bmd
Cool Scooby
 
bmd's Avatar
 
Join Date: Apr 2007
Location: N.I.
Posts: 201
Re: CEL-another question!

no worries pete, sorry about the wrong forum
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost question scooby_steve Engine Bay 10 27 Feb 2008 07:05 PM
Podiums out of the question, claims Alonso. News_Bot Formula News 0 21 Feb 2008 11:01 AM
Hello Everyone VF Series Turbo Question Jordy Subaru Impreza Discussions 74 31 Oct 2006 04:57 PM
Time running out to question Lewis. News_Bot Formula News 0 14 Aug 2006 03:00 PM


All times are GMT. The time now is 01:12 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.