Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

newbie with no power to my radio
Reply
 
LinkBack Thread Tools Display Modes
Old 25 Apr 2012, 04:04 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 2
newbie with no power to my radio

hey. i have 2003 wrx and i have no power to the sterio at all, ive checked all the nessary fuses and they all seem to be fine. i have ony just got the car and it hasnt worked from the start. i know the person who sold it to me and they assure me that it did work before she blew the main fuse by crossing the battery terminals whilst trying to charge. could this have ruined the radio or am i just missing somthing? all the other electrics are working fine.
any advice would be great thanks
Offline   Reply With Quote
Old 26 Apr 2012, 10:02 AM   #2 (permalink)
Senior Scooby
 
scoobymike79's Avatar
 
Join Date: Sep 2009
Location: Lincolnshire
Posts: 1,730
Re: newbie with no power to my radio

Did you check ALL your fuses, even the ones that aren't related? If all are ok you need to test the live feed to the stereo and the earth which will be a lot easier with the stereo removed
__________________
"Straight roads are for fast cars, turns are for fast drivers." -Colin McRae
Offline   Reply With Quote
Old 26 Apr 2012, 07:34 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 2
Re: newbie with no power to my radio

Yeah id checked them all. I had a friend put a volt meter on the back of the stereo for me tonight and theres no power geting to the permanent live wire, so we rechecked the fuses and there all ok. This is starting to sound expensive! any more ideas???
Offline   Reply With Quote
Old 29 Apr 2012, 10:38 PM   #4 (permalink)
Fresh Scooby
 
steveuk260's Avatar
 
Join Date: Mar 2012
Location: Bedfordshire
Posts: 13
Send a message via MSN to steveuk260 Send a message via Yahoo to steveuk260 Send a message via Skype™ to steveuk260
Re: newbie with no power to my radio

U sure you connected radio to the right connection, my 2000 turbo has 2 identical connections one works the other doesn't.
Offline   Reply With Quote
Old 30 Apr 2012, 03:30 PM   #5 (permalink)
Senior Scooby
 
scoobymike79's Avatar
 
Join Date: Sep 2009
Location: Lincolnshire
Posts: 1,730
Re: newbie with no power to my radio

Try running a new permanent live wire from your battery and see if this works. You can buy a cable from Halfords with a fuse in and just run it through
__________________
"Straight roads are for fast cars, turns are for fast drivers." -Colin McRae
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Interference Darren Critch Electrical (Including ICE) 4 02 Mar 2010 07:30 PM
radio problems help subbie05 Interior 4 14 Aug 2008 07:28 AM
low power and power surges at high revs tony5144 Subaru Impreza Discussions 2 10 Apr 2008 04:53 PM
WRC Radio Nelson General Chat - Anything about Anything 2 18 Sep 2004 10:00 AM
Clutch / Radio EH?! triplezoney Technical General 16 05 Jul 2004 10:00 PM


All times are GMT. The time now is 01:24 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.