Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Electrical (Including ICE)

Subaru Impreza Forum

Error code P00420
Reply
 
LinkBack Thread Tools Display Modes
Old 03 Apr 2012, 10:29 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 6
Error code P00420

Hi all, Sweden calling. I'm new here and to be honest - I know just about nothing about Imprezas. My daughter's boyfriend bought a 2005 (I think) WRX in Britain last summer and now he is trying to get it registered in Sweden. He tried to get it through the Swedish MOT yesterday and there were some easy solved problems and one not so easy to solve problem. The check engine light is always on and I tried to help him with it today. I have a code reader and it says P0420 (=Catalyst System Effiecency Below Threshold Bank 1). I tried to use the code reader to erase the code but nothing changes. The light just comes on as soon as the ignition is tured on again. The motor doesn't even have to be started. The motor works fine and according to the MOT-man there is nothing wrong with the exhausts. Has anyone got any ideas of what to do? Any suggestions would be highly appreciated.
Offline   Reply With Quote
Old 03 Apr 2012, 11:12 AM   #2 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Error code P00420

Possibly a problem with the rear 02 sensor or the cat itself
Offline   Reply With Quote
Old 03 Apr 2012, 11:17 AM   #3 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Error code P00420

common code with a decat pipe tbh
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 03 Apr 2012, 02:46 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 6
Re: Error code P00420

Thank you for the answers. Perhaps I should have told you the car was used without a cat and with a sports exhaust system until a few days ago when all the original bits went back on again. Earlier the check engine light only came on when driving at motorway speeds and then was turned off when slowing down. Earlier the ECU was reset by disconnecting the negative battery lead. That trick doesn't work any longer and resetting with my code reader won't work either. Do you think the O2 sensor might have been damaged by hot fumes since this car is supposed to deliver 340 bhp which of most are used from time to time?
Offline   Reply With Quote
Old 03 Apr 2012, 03:24 PM   #5 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Error code P00420

You can reset the codes with a vag lead and laptop. If the car has been mapped for no cat it should be mapped again for running with one
Offline   Reply With Quote
Old 03 Apr 2012, 04:04 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 6
Re: Error code P00420

Thank you Shambles, I don't know when or if the car has been mapped at all. I know bits and pieces have been changed to get more power and I know the CE light used to come on only at high speeds earlier. I must admit I had never heard of a vag lead before when I just read about it in your reply. I checked for one on ebay and it seems to something used on VW/Audi/Skoda. Did I find the right lead? Please enlighten me.
Offline   Reply With Quote
Old 03 Apr 2012, 04:23 PM   #7 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Error code P00420

That's the one - then use romraider (free os software)
Offline   Reply With Quote
Old 03 Apr 2012, 04:53 PM   #8 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 6
Re: Error code P00420

Thanks again. Before I order any equipment I feel like I have to ask: How come the VW cables work and not others? I noticed on the Romraider site they recommend Tactrix cables. I checked those out too and they appear to be a lot more expensive than the VAG leads. Also Romraider says a Reflash connector is needed. Will I have to get one of those from Tactrix or this something VAG has too?
Offline   Reply With Quote
Old 03 Apr 2012, 05:53 PM   #9 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Error code P00420

Tactrix can be used for mapping. Vag can be used for reading. The reflash connector is so you can flash a new map to you're ecu. The extra money for the tactrix isn't worth it unless you're going to learn how to map it too. And for that you'll need det cans and a wideband O2 sensor and you'll have to learn alot. Vag will do everything that you need regarding your OP
Offline   Reply With Quote
Old 03 Apr 2012, 06:22 PM   #10 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Error code P00420

If it had a de cat fitted I would say the car had been mapped for this, now you have fitted a cat you have done the opposite to what a de cat does on a standard car.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 03 Apr 2012, 08:00 PM   #11 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 6
Re: Error code P00420

So, if bugeye_bob is right a VAG lead won't work - a Tactrix or similar equipment will be needed? I phoned the proud owner tonight. Today it is Tuesday and he is on his way for a sea cruise on the Baltic sea. The Impreza must be ready to have a second test on Thursday so I doubt there will be time to get this problem sorted in time. I know he has friends who probably own electronic equipment that might help. Their equpment together with the help I have got here might solve the problem. I'll come back here and tell you how things develop. Until then - if anyone has other ideas - please let me know.
Offline   Reply With Quote
Old 03 Apr 2012, 10:03 PM   #12 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Error code P00420

You could try the Evo sites, the same lead can do both cars(some leads can) so If by some miracle you find a owner with a lead close its a easy flash to sort your problem.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 04 Apr 2012, 12:39 PM   #13 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 6
Re: Error code P00420

How can you see what ECU is fitted? Is it clearly marked on the outside?
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Code 32! pot1175 Electrical (Including ICE) 12 22 Jan 2014 06:34 PM
Error Code 54 beyazit60 Technical General 2 12 Mar 2012 10:28 AM
error code classiccarl Engine Bay 3 11 Mar 2009 10:01 PM
error code 31 woodo Technical General 0 09 Mar 2009 06:01 PM
Error Code 43 andyng Engine Bay 7 22 Apr 2006 07:03 AM


All times are GMT. The time now is 05:56 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.