Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru-Impreza.org > Announcements

Subaru Impreza Forum

temp problems
Reply
 
LinkBack Thread Tools Display Modes
Old 01 Jan 2011, 12:28 AM   #1 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
temp problems

first ov all,excellent threads,some usefull info
here is my propblem--i have a 99 impreza turbo,recently i changed the rad,as had a small crack in plastic housing,no probl;ems b4 i changed just leaking water out rad,so i fixed the prob ,(bought new rad) anyways
now my car on ide is blows cold air,dosent overheat,no bubbles in water ,no gunk etc in oil,but when i drive ,temp goes right up,so i have to stop and let cool down,no leaks etc,
any recomendations ide love,as doing my head in now
Offline   Reply With Quote
Old 01 Jan 2011, 01:56 AM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: temp problems

Theirs air trapped in the system bleed the system and bobs your uncle job done
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 01 Jan 2011, 08:30 AM   #3 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: temp problems

Try this: Undo the radiator type cap on the expansion tank when the water is cold and then squeeze the rad top and bottom hoses aswell as smaller heater hoses. You may see bubbles in the top as you do it "thats good",once your happy theres no more air try starting the car with the lid still off. (KEEP AN EYE ON IT) as it circulates, put the cap back on after 5 or 10 mins.
__________________
Pete.

Offline   Reply With Quote
Old 01 Jan 2011, 12:54 PM   #4 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
Re: temp problems

thanks will give this a go,and post back,been trying for 2days now,so fingers crossed;0)
Offline   Reply With Quote
Old 01 Jan 2011, 06:09 PM   #5 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
Re: temp problems

i bled all the system,but still the same,i really think my water pump is on its way out,as it made a chattering noise,so im wondering this is why the water isnt circulating?top pipe hot,bottom cold,pipes that go into car for heaters,one was hot,one was cold?
hope its just my water pump now,
Offline   Reply With Quote
Old 01 Jan 2011, 07:54 PM   #6 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: temp problems

getting the air out of the system on a Impreza is art form lol,
Id been 100% sure before you start spending any money.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 01 Jan 2011, 09:53 PM   #7 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
Re: temp problems

wow -only taken me 3 days nearly,but yes ive sorted it,took the stat out,tested it worked fine(opened/closed) water test,popped it back in ,but this time i left the little overflow pipe off,on top hose,then filled it up,with fluid and water,ran cold,gave it a little bit of peddle,hey pressto,heat in cab at last ,didnt overheat left on idle for 10/15 mins,still hot in cab,prob solved,thanks use guys,
some really good info,
__________________
steve
Offline   Reply With Quote
Old 01 Jan 2011, 10:05 PM   #8 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: temp problems

Would check the level over the next few days as you might get some more air finding it's way to the top
Offline   Reply With Quote
Old 01 Jan 2011, 10:15 PM   #9 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
Re: temp problems

will def keep an eye on it,dont want that again,ide rather take an engine out,heads up to all that helped ;0)
__________________
steve
Offline   Reply With Quote
Old 02 Jan 2011, 10:03 AM   #10 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: temp problems

most leave the header tank cap off and leave it idling until the fans have come on and gone off twice, checking the water and topping up if required(and with a good mix of anti freeze)
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 02 Jan 2011, 12:35 PM   #11 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
Re: temp problems

did that,runs sweet again ,very happy,thanks for the help
__________________
steve
Offline   Reply With Quote
Old 07 Jan 2011, 08:00 PM   #12 (permalink)
Young Scooby
Paid & Proud
 
stev1193's Avatar
 
Join Date: Jan 2011
Location: cumbria
Posts: 68
Re: temp problems

thanks for your help in this,was the water pump,had shearedthe fin of the back of pump,
__________________
steve
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp Sensor location 2002 empreza Muggy Technical General 10 28 Aug 2012 06:32 AM
Water temp Gauge SteveG7 Electrical (Including ICE) 0 27 Dec 2010 03:55 AM
Mosley: F1 problems are 'the FIA's fault'. News_Bot Formula News 0 11 Dec 2008 12:24 PM
Hirvonen questions if problems are tactics. News_Bot Rally News 0 29 Aug 2008 10:10 PM
General Problems after new server skylight General Chat - Anything about Anything 2 17 Aug 2004 07:16 AM


All times are GMT. The time now is 05:52 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.