View Single Post
Old 09 Feb 2005, 11:18 AM   #1 (permalink)
torrekens
Cool Scooby
 
torrekens's Avatar
 
Join Date: Feb 2005
Location: North-West Finland
Posts: 419
Send a message via MSN to torrekens
STi braking problem ! Anybody else experienced this ?

I have a problem with a 2003 Impreza STi neither Subaru or Prodrive has ever experienced: brake discs glazing up when driving on wet roads by cold weather.

If you drive down a really wet and cold motorway at night at a stabilised speed (let's say 70 or 80mph or our camera infested roads), you hardly need to brake. If ever you don't touch the brakes for 3 or 4 minutes (i.e. 4 or 5 miles) and then want to brake the first time, there is NO GRIP AT ALL anymore on the discs. You can stand on the brakes and it's as if somebody has taken away the brake assist, fitted 4 drums around and hitched a twin-axle unbraked caravan to your car !

I'd like to know if anybody ever had the problem and has found a cure.

Note: tried Prodrive for cross-drilled discs, but these do not exist there for the STi, if you need to stay on 17" at least. (which I need to as in winter in need studded tyres in Finland...).
Offline   Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177