View Single Post
Old 03 Jan 2018, 09:16 PM   #7 (permalink)
alunian
Scooby Fanatic
 
alunian's Avatar
 
Join Date: Aug 2010
Posts: 795
Re: Help running problem fuel issue ?

Quote:
Originally Posted by sambruce02 View Post
Well mate

I will tell you Sunday after i fit a up rated pressure regulator , I could just have a fault with my regulator

Looking at fuel pressure when I remove the vac pipe off the regulator fuel pressure did not change even when I apply a vac with a mitivac

But if my fuel pressure is at 3.8 bar for what I can gather my regulator my standard reg has a safety open pressure relief at 4.0 bar and I think it's goin over dumping my pressure giving me pressure prob dunno

I'm lucky I'm a mechanic I already wiped the pump back out and checked and it's all sat right

I never had a problem with the Walbro only that it lasted 10 months ha

If anyone can help me still much appreciated
Did you manage to sort your fuel pressure issue out?

I've had the Roger Clark fuel pump fitted with the orignal subaru sock for a few weeks and it seems ok so far, I still need to test it with less than quarter of tank of fuel to make sure its picking up ok.
__________________
Jack Burton, Big Trouble In Little China: This is Jack Burton in the Porkchop Express and I'm talkin' to whoever's listening out there.
Offline   Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177