View Single Post
Old 26 Dec 2007, 10:03 PM   #1 (permalink)
ozbod1
Regular Scooby
 
Join Date: Nov 2007
Posts: 100
Angry advice please, engine light on ONCE AGAIN...

hi guys i need some advice please, engine light came on around a month ago so i took it to subaru and needed a new cam sensor so {190} later alls well then a week later the lights on again so took it back and it had a misfire on cyllinder 1 so left it with them and they said it was a loose wire on the coil pack so they fixed it at no charge, now 2 weeks later its back on but the funny thing it did exactly the same thing as before on a bumpy road the engine light flashed a few times then 40 miles later it came on permanent and i was sure it would, the cars a 2002 wrx bugeye by the way!! so would like advice on should i take it back to subaru or just disconect the neg on the battery and press the brake etc, im concerned that if it does have a misfire again it could cause damage?? also can anyone tell me if this engine light thing is goin to be a regular thing as i love my scoobie but the light thing is getting me down, ive had a alpina bm since 1994 and its never seen a main dealer other than services, please let me know what you think?? soz for boring you to death, thanks in advance
Offline   Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177